Bug 874669

Summary: Upgrade to juddi 3.1.4
Product: [JBoss] JBoss Enterprise SOA Platform 5 Reporter: tcunning
Component: JBossESBAssignee: tcunning
Status: ON_QA --- QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.3.1CC: soa-p-jira
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
It is desired that integration with jUDDI be upgraded for jUDDI version 3.1.4.
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
jUDDI database DDL upgrade statements none

Description tcunning 2012-11-08 15:46:29 UTC
Description of problem:
Need to upgrade jUDDI to version 3.1.4

Comment 1 tcunning 2012-11-08 15:50:53 UTC
Need to create a jUDDI 3.1.4 for the linked issue and incorporate it.

Comment 2 tcunning 2012-11-20 17:46:04 UTC
Created attachment 648690 [details]
jUDDI database DDL upgrade statements

Comment 3 tcunning 2012-11-20 17:48:39 UTC
Moving to jUDDI 3.1.4 will require some changes to the schema scripts.     There are a number of create table statements, and a number of alter table statements (adding indices).     I've attached the patch file which shows the differences in the DDL for new installs - I think these will have to be added to the changes which are applied to existing installs.

Comment 4 JBoss JIRA Server 2012-12-03 17:50:52 UTC
Tom Cunningham <tcunning@redhat.com> updated the status of jira JBESB-3885 to Resolved

Comment 5 JBoss JIRA Server 2012-12-03 17:50:56 UTC
Tom Cunningham <tcunning@redhat.com> updated the status of jira JBESB-3885 to Closed