Bug 875129

Summary: epub output generates HTML files with irregular DOCTYPEs (XHTML 1.0 Strict instead of XHTML 1.1)
Product: [Community] Publican Reporter: Raphaël Hertzog <raphael>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.0CC: mhusnain, r.landmann, rlandman
Target Milestone: 3.2   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 3.2.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-08-09 00:49:23 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Raphaël Hertzog 2012-11-09 10:26:19 EST
publican epub's output includes HTML files using "XHTML 1.0 Strict" as DOCTYPE when the recommendation for epub is apparently "XHTML 1.1".

This is diagnosed by epubcheck 3.0-RC1:

WARNING: /home/rhertzog/x/tdah/publish/en-US/Debian/6.0/epub/debian-handbook/Debian-6.0-debian-handbook-en-US.epub/OEBPS/debian-packaging.html: Irregular DOCTYPE: found '-//W3C//DTD XHTML 1.0 Strict//EN', expecting '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd"
>'.

This error has been reproduced with the Debian Handbook:
$ git clone git://anonscm.debian.org/debian-handbook/debian-handbook.git
Comment 1 Jeff Fearn 2013-07-09 02:53:19 EDT
$ grep DOCTYPE build/en-US/epub/OEBPS/index.html
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

To ssh://git.fedorahosted.org/git/publican.git
   33e04d3..4dffa35  HEAD -> devel
Comment 2 HSS Product Manager 2013-07-09 02:57:33 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 3 Misha H. Ali 2013-07-21 20:07:00 EDT
Attempted to verify but steps to check problem are missing so unsure if this is correct procedure:

1. Check out a publican book from SVN.
2. Run "publican build --langs en-US --formats epub"
3. cd tmp/en-US/epub/OEBPS
4. Opened a random html file with gedit
5. Searched for "XHTML", found the following:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

Result:

Looks like this is still XHTML 1.0 Strict. Setting bug back to ASSIGNED.
Comment 4 Misha H. Ali 2013-07-21 21:14:23 EDT
Sorry, looks like my publican has inexplicably reverted to the non-dev version over the weekend. Setting up dev version again to re-test this bug.
Comment 5 Misha H. Ali 2013-07-21 22:11:23 EDT
Fixed issue caused by yum update. Tested with publican-3.1.5-0.fc19.t62.noarch 

Followed steps from comment#3

Result:

Found the following information:

!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd"><html xmlns="http://www.w3.org/1999/xhtml">

Looks like XHTML version is 1.1 rather than 1.0 as expected.
Comment 6 Jeff Fearn 2013-08-09 00:49:23 EDT
The fix for this bug has been shipped in publican 3.2.0