Bug 875216

Summary: Kernel update for nfsroot host results in "mount.nfs: Protocol not supported" error on boot
Product: [Fedora] Fedora Reporter: Peter McNabb <peter>
Component: dracutAssignee: dracut-maint
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 17CC: dracut-maint, goeran, harald, jonathan
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-29 13:16:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Peter McNabb 2012-11-09 20:40:52 UTC
Description of problem:
At some point during F17 release, the NFS-related kernel modules changed so that a new nfsv3 module needs to be loaded to mount an NFS export. The initramfs created by dracut does not include the newer modules (in my case "nfsv3" and "nfs_acl" are required) and a host that attempts to mount its root filesystem over NFS fails with the message "mount.nfs: Protocol not supported".

It can be worked around by re-running dracut with the option '--add-drivers "nfsv3 nfs_acl"' after installing the new kernel.

It looks like this is already fixed in dracut (commit ba111df2b99f9f1dc5c51442ad92bcefbf16bd91) and part of release dracut-024, but that version is only being built for F18.

Version-Release number of selected component (if applicable):
Ok in 3.4.6-2.fc17.x86_64, definitely broken in 3.6.5-1.fc17.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Update to latest kernel package
2. Copy dracut-generated initramfs to tftp server
3. Configure pxelinux to use new initramfs
4. Reboot host
  
Actual results:
Host fails to boot with the error "mount.nfs: Protocol not supported"

Expected results:
Host boots

Comment 1 Peter McNabb 2012-11-09 20:55:40 UTC
I should add that the version of dracut is dracut-018-105.git20120927.fc17.noarch (used with both kernel versions mentioned).

Comment 2 Harald Hoyer 2013-05-29 12:56:06 UTC
commit ba111df2b99f9f1dc5c51442ad92bcefbf16bd91

Comment 3 Harald Hoyer 2013-05-29 13:16:49 UTC

*** This bug has been marked as a duplicate of bug 869180 ***