Bug 87525

Summary: bind-9.2.2-3 doesn't work on on-NPTL kernels
Product: [Retired] Red Hat Raw Hide Reporter: Jonathan Kamens <jik>
Component: bindAssignee: Daniel Walsh <dwalsh>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: mitr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-07 19:15:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jonathan Kamens 2003-03-28 14:18:17 UTC
named hangs during startup when bind-9.2.2-3 is installed on a machine running a
non-NPTL kernel.  Name resolution clients also seem to hang or at least take an
extraordinarily long time to exit after printing errors.  Downgrading to
bind-9.2.1-16 makes the problem go away.

Comment 1 Daniel Walsh 2003-04-07 12:17:24 UTC
Raw Hide versions are built to run on the Latest OS using nptl.  You need to
build  from the src rpm.

Dan

Comment 2 Jonathan Kamens 2003-04-07 14:10:42 UTC
There seems to be some disagreement about whether Red Hat packages should work
on non-NPTL kernels.  Several Red Hat employees maintained throughout the beta
cycle for this release that continuing to work on non-Red-Hat, non-NPTL kernels
was a requirement for the release.  This position was reiterated as recently as
March 27 on testers-list; see
<https://listman.redhat.com/mailman/private/testers-list/2003-March/028819.html>.


Comment 3 Daniel Walsh 2003-04-07 19:15:25 UTC
Ok I think I know what the problem was.  We rebuilt 2.2.3 - 2.2.7 using Posix
threads to try to fix the shutdown problem on RH 9.  The problem wasn't related
to Posix threads so we removed the change in 2.2.8.  Since kernels without NPTL
don't handle Posix Threads correctly Bind would be broken on them.  Try 2.2.8 to
see if this fixed the problem.

Dan