Bug 875259

Summary: Machines installed after F18 upgrade, will not boot.
Product: [Fedora] Fedora Reporter: William Brown <william>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: berrange, clalancette, dallan, itamar, jforbes, jyang, laine, libvirt-maint, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-13 19:10:44 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Log output from messages, audit and libvirt.
none
Created in F17 (working VM)
none
Created in F18 - won't boot none

Description William Brown 2012-11-09 18:26:53 EST
Created attachment 641884 [details]
Log output from messages, audit and libvirt.

Description of problem:
VM's from disks imported from my F17 instance boot correctly.

Machines boot from CD/DVD and can be installed, but once installed, hang at "Booting from Hard Disk".

There don't appear to be SELinux denials to the Disk images, and permissions are correctly set to william:qemu 660 on the images. 

I have attempted to install both CentOS and Fedora in VMs. This issue affected both of them. 

Find the logs of this attached. 

Please note, the last line "terminating" the VM, is my force off action, 20 seconds after the "hang" occurs.
Comment 1 Dave Allan 2012-11-09 21:29:12 EST
Can you provide the domain xml for a machine that boots and a machine that does not?  Also, how did you create the VMs, virt-manager?
Comment 2 William Brown 2012-11-09 22:34:41 EST
Created attachment 641985 [details]
Created in F17 (working VM)
Comment 3 William Brown 2012-11-09 22:35:58 EST
Created attachment 641986 [details]
Created in F18 - won't boot

This machine installed CentOS 6 cleanly, but upon the first reboot, hung at "Booting from Hard disk"
Comment 4 William Brown 2012-11-09 22:46:31 EST
Don't mind the Disk bus type - I tried if the VM's would boot from something other than virtio to eleminate different possibilites.
Comment 5 William Brown 2012-11-13 19:10:44 EST
This now works again from the latest update of libvirt in updates-testing - The machines needed a reinstall though.