Bug 875664

Summary: “አማርኛ (ኢትዮጵያ) Amharic (Ethiopia)” is displayed with a box between “አማርኛ” and “(ኢትዮጵያ)” in anaconda at the beginning of the installation
Product: [Fedora] Fedora Reporter: Mike FABIAN <mfabian>
Component: loraxAssignee: Brian Lane <bcl>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: anaconda-maint-list, bcl, elad, fonts-bugs, g.kaviyarasu, i18n-bugs, jonathan, mclasen, mfabian, mshao, sbueno, tagoh, vanmeeuwen+fedora, vpodzime
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: lorax-19.5-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-08-28 19:00:48 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
rendering-problem-in-amharic-in-anaconda.png
none
rendering-problem-in-amharic-in-anaconda-f19-Alpha-TC1.png
none
rendering-problem-in-amharic-in-anaconda-fixed-in-f19-TC5.png none

Description Mike FABIAN 2012-11-12 05:27:08 EST
Created attachment 643379 [details]
rendering-problem-in-amharic-in-anaconda.png

Tested on Fedora-18-Beta-TC8-x86_64-netinst.iso

See attached screenshot.
Comment 1 Mike FABIAN 2012-11-12 05:30:03 EST
The box in the screenshot shows the codepoint U+0020 SPACE.

Weird that the space is not rendered correctly.
Comment 2 Mike FABIAN 2012-11-12 05:37:23 EST
Vratislav explained to me where the string comes from,
the string can be checked like this:

$ python
Python 2.7.3 (default, Jul 24 2012, 10:05:38) 
[GCC 4.7.0 20120507 (Red Hat 4.7.0-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import babel
>>> babel.Locale.parse("am_ET.UTF-8").display_name
u'\u12a0\u121b\u122d\u129b (\u12a2\u1275\u12ee\u1335\u12eb)'
>>> babel.Locale.parse("am_ET.UTF-8").display_name.encode('utf8')
'\xe1\x8a\xa0\xe1\x88\x9b\xe1\x88\xad\xe1\x8a\x9b (\xe1\x8a\xa2\xe1\x89\xb5\xe1\x8b\xae\xe1\x8c\xb5\xe1\x8b\xab)'
>>> print babel.Locale.parse("am_ET.UTF-8").display_name
አማርኛ (ኢትዮጵያ)
>>> 

Which looks OK.
Comment 3 Mike FABIAN 2012-11-12 05:56:07 EST
So this does not look like an anaconda but actually.

Seems more likely to be a font/rendering bug, i.e. something
in Gtk/Pango.
Comment 4 Mike FABIAN 2012-11-12 05:57:14 EST
pango-view on Fedora 17 displays the string correctly though using
the font /usr/share/fonts/sil-abyssinica/AbyssinicaSIL-R.ttf
Comment 5 Akira TAGOH 2012-11-12 09:01:08 EST
It seems working on Fedora-18-Beta-TC8-x86_64-Live-Desktop.iso

So likely missing a font in netinst perhaps.
I see the following fonts available on Live:

$ fc-list :lang=am
/usr/share/fonts/sil-abyssinica/AbyssinicaSIL-R.ttf: Abyssinica SIL:style=Regular
/usr/share/fonts/gnu-free/FreeSerif.ttf: FreeSerif:style=Regular,нормален,normaयNormálne,ปกติ,menengah,прямій,Navadno,vidējs,normalusis,عادی,vừa,Arrunta,सामान्ый
Comment 6 Akira TAGOH 2012-11-12 21:10:57 EST
On Fedora-18-Beta-TC8-x86_64-netinst.iso

$ fc-list :lang=am
/usr/share/X11/fonts/TTF/GohaTibebZemen.ttf: Goha\-Tibeb Zemen:style=Regular

Which is owned by xorg-x11-fonts-ethiopic.
and I can reproduce this with:

$ pango-view --markup -t '<span font="Goha-Tibeb Zemen 10">አማርኛ (ኢትዮጵያ)</span>'

There should be two issues here. 1) Amharic support in Goha-Tibeb Zemen is broken. 2) we should consider to use another fonts for installation.
Comment 7 Mike FABIAN 2012-11-13 00:08:51 EST
/usr/share/X11/fonts/TTF/GohaTibebZemen.ttf indeed lacks ASCII completely,
it even lacks the space.

It has *only* Amharic.
Comment 8 Nicolas Mailhot 2012-11-13 03:59:55 EST
Yes this is an old font and I'm not even sure it would be licensing-clean if we audited it today

We have many more modern Amharic fonts in the distro (senamirmir fonts, sil Abyssinica…)
Comment 9 Elad Alfassa 2012-11-13 08:36:47 EST
(In reply to comment #8)
> Yes this is an old font and I'm not even sure it would be licensing-clean if
> we audited it today
Then we should audit it.
> 
> We have many more modern Amharic fonts in the distro (senamirmir fonts, sil
> Abyssinica…)
In that case we should include them by default instead of GohaTibebZemen.
Comment 10 Akira TAGOH 2012-11-20 01:15:01 EST
nim-nim and others:
So what's our consensus for alternative font of xorg-x11-fonts-ethiopic? apparently the packages which explicitly set any alias name in fontconfig config file is only sil-abyssinica-fonts and is serif though.
Comment 11 Nicolas Mailhot 2012-11-20 05:20:08 EST
abyssinica is the most recent and has been updated to latest unicode standards. Senamirmir fonts have more weights. I don't know if the coverage differences are significant to users. None of those is sans-serif as it seems sans-serif is not used much by Amharic users.

My advice would be to ask locals for preferences if we have a l10n Amharic group.

I'm pretty sure xorg-x11-fonts-ethiopic is bad.
Comment 12 A S Alam 2012-12-06 02:23:48 EST
*** Bug 884407 has been marked as a duplicate of this bug. ***
Comment 13 Mike FABIAN 2013-03-21 10:10:56 EDT
Created attachment 713865 [details]
rendering-problem-in-amharic-in-anaconda-f19-Alpha-TC1.png

The problem is still unchanged  in Fedora-19-Alpha-TC1.
Comment 14 Mike FABIAN 2013-05-09 03:04:07 EDT
The problem still exists in Fedora-19-Beta-TC3.
Comment 15 Fedora Admin XMLRPC Client 2013-05-14 08:14:03 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 16 Mike FABIAN 2013-05-26 07:08:01 EDT
The problem still exists in Fedora-19-Beta-RC4.
Comment 17 Mike FABIAN 2013-06-07 02:50:34 EDT
The problem still exists in Fedora-19-TC1.
Comment 18 Akira TAGOH 2013-06-07 05:35:42 EDT
This isn't a pango bug at all, we just need to change the font for Amharic in the installation image. xorg-x11-fonts-ethiopic isn't suitable according to the above comments, we should change to sil-abyssinica-fonts at least - we can change it later if Amharic people in Fedora community isn't comfortable with it. that would be better than broken font anyway. reassigning to lorax.
Comment 19 Mike FABIAN 2013-06-18 02:18:04 EDT
Fixed in Fedora-19-TC5-x86_64-netinst.iso.
Comment 20 Mike FABIAN 2013-06-18 02:21:58 EDT
Created attachment 762337 [details]
rendering-problem-in-amharic-in-anaconda-fixed-in-f19-TC5.png