Bug 875947

Summary: openstack-swift does not contain a dependency for python-iso8601
Product: [Fedora] Fedora EPEL Reporter: Joseph W. Breu <breu>
Component: openstack-swiftAssignee: Derek Higgins <derekh>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: el6CC: apevec, apevec, breu, david, d.busby, derekh, jonathansteffan, markmc, rbryant, silas, zaitcev
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-22 23:15:58 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Joseph W. Breu 2012-11-12 17:05:18 EST
openstack-swift does not contain a dependency for python-iso8601

swift-proxy will not start up without python-iso8601.
Comment 1 Pete Zaitcev 2012-11-12 19:11:58 EST
*** Bug 875948 has been marked as a duplicate of this bug. ***
Comment 2 Derek Higgins 2012-11-13 06:06:24 EST
Hi Joseph,
   If you got a stack trace can you add it, i cant reproduce the problem, it may be middleware you have added. Also what versions of the packages are you using, I've tried two, see below


[root@instance-1352801501 ~]# rpm -qa | grep -i -e openstack-swift -e iso8601
openstack-swift-plugin-swift3-1.0.0-0.20120711git.el6.noarch
openstack-swift-1.7.4-2.el6.noarch
openstack-swift-proxy-1.7.4-2.el6.noarch

[root@instance-1352801501 ~]# service openstack-swift-proxy status
proxy-server (pid  2959) is running...



[root@instance-1352803971 ~]# rpm -qa | grep -i -e openstack-swift -e iso8601
openstack-swift-proxy-1.4.8-5.el6.noarch
openstack-swift-1.4.8-5.el6.noarch

[root@instance-1352803971 ~]# service openstack-swift-proxy status
proxy-server (pid  2336) is running...
Comment 3 Pete Zaitcev 2013-03-22 23:15:58 EDT
Fixed in 1.7.4-3, possibly by accident, when Martin added a dependency
on python-keystone, which in turn pulls python-iso8601.

Looking what middleware needs what should be responsibility of the user,
generally speaking. But Keystone is rather common, so whatever. It's all
well that ends well, hopefuly Joseph likes this fix.

Closing.
Comment 4 Pete Zaitcev 2013-03-22 23:19:19 EDT
(Forgot to mention that Fedora continues unchanged - I just checked in F18.
Silas is on Fedora, so this does not apply to him. BTW, upstream keeps
shuffling Keystone middleware from place to place. Maybe we should de-dup
bugs and track thus?)