Bug 876400

Summary: Doc Text column display should wrap
Product: [Community] Bugzilla Reporter: mark yarborough <myarboro>
Component: User InterfaceAssignee: Matt Tyson <mtyson>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.2CC: jingwang, mtyson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 4.4-3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-20 07:05:29 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
screenshot for comment8(limited to 1000 bugs)
none
screenshot for comment8(full buglist) none

Description mark yarborough 2012-11-13 21:45:40 EST
Description of problem: When "Doc Text" column is included in
query result, the text does not wrap. Since there is frequently
a lot of text in this field, it pushed all columns to the right
of Doc Text out of view. 

Version-Release number of selected component (if applicable):

How reproducible: Always


Steps to Reproduce:
1. Display bugs with multi-line Doc Text content
2. Use "Change Columns" to display Doc Text with other columns to right
3. The Doc text column pushes other off screen to right...
  
Actual results:
Doc Text does not wrap.


Expected results:
Doc Text should wrap.

Additional info:
Comment 3 Matt Tyson 2013-02-06 19:57:17 EST
The doc text will now line wrap at a reasonable limit and no longer clobber the page.
Comment 6 wangjing 2013-05-07 01:56:27 EDT
Verified on qe test env version 4.4.rc2-3(20130426) --> Fail

Verify steps(amount to add one extra step in comment5):
1. on Advanced search page, set condition 'Doc Text: is not null ' in Custom Search section, click button search.
2. on the returned buglist page, click link in 'This result was limited to 1000 bugs. See all search results for this query.' on the top.
3. on the returned buglist page, check if the Doc text column pushes other columns off screen to right.

then expected result:  the Doc text column doesn't push other columns off screen on the right side. It should wrap.

Actual results:
the Doc text column was pushing other columns off screen on the right side. It does not wrap.
Comment 7 Simon Green 2013-05-07 21:47:02 EDT
(In reply to comment #6)
> Actual results:
> the Doc text column was pushing other columns off screen on the right side.
> It does not wrap.

It does wrap. There are many bugs that have multiple lines of doc type information.

Remember there are some bugs (for example 692338, 692552, 692555 and 693617) that have many hundreds of characters between spaces or dashes. This will determine the minimum width of the column. There is absolutely nothing that can be done about that.
Comment 8 wangjing 2013-05-10 02:59:50 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Actual results:
> > the Doc text column was pushing other columns off screen on the right side.
> > It does not wrap.
> 
> It does wrap. There are many bugs that have multiple lines of doc type
> information.
> 
> Remember there are some bugs (for example 692338, 692552, 692555 and 693617)
> that have many hundreds of characters between spaces or dashes. This will
> determine the minimum width of the column. There is absolutely nothing that
> can be done about that.

attached two screenshots for contrast:
1) the buglist limited to 1000 bugs: the doc text wrapped.(comment5)
2) the buglist after  clicking 'See all search results for this query': the doc text does not wrap.(comment6)
Comment 9 wangjing 2013-05-10 03:01:11 EDT
Created attachment 745976 [details]
screenshot for comment8(limited to 1000 bugs)
Comment 10 wangjing 2013-05-10 03:01:56 EDT
Created attachment 745977 [details]
screenshot for comment8(full buglist)
Comment 11 Simon Green 2013-05-12 17:44:38 EDT
Verified by IED. Attachment 745977 [details] does show wrapping. Comment 7 explains why the wrapping isn't as tight as the first screenshot.
Comment 12 wangjing 2013-05-16 07:00:22 EDT
(In reply to comment #11)
> Verified by IED. Attachment 745977 [details] does show wrapping. Comment 7
> explains why the wrapping isn't as tight as the first screenshot.

According to Attachment 745977 [details], it's really like reporter's description 'The Doc text column pushes other off screen to right...' in comment0. So it couldn't meet the requirement.

due to comment7, 'Remember there are some bugs (for example 692338, 692552, 692555 and 693617) that have many hundreds of characters between spaces or dashes. This will determine the minimum width of the column. There is absolutely nothing that can be done about that.'

so QE suggest close this bug cantfix, rather than verified.
thanks!