This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 877576

Summary: Dutch translation for anaconda is Polish
Product: [Fedora] Fedora Localization Reporter: Steve Tyler <stephent98>
Component: Dutch [nl]Assignee: Geert Warrink <geert.warrink>
Status: CLOSED CURRENTRELEASE QA Contact: Geert Warrink <geert.warrink>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: awilliam, geert.warrink, g.kaviyarasu, info, johannbg, jonathan, kparal, piotrdrag, rbergero, robatino, sbueno, stephent98, tflink, vanmeeuwen+fedora
Target Milestone: ---Keywords: i18n
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedNTH RejectedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-08-10 12:53:12 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752664    

Description Steve Tyler 2012-11-16 18:07:01 EST
Description of problem:
The Dutch translation for anaconda is Polish. Verified at Transifex:
https://fedora.transifex.com/projects/p/anaconda/resource/master/l/nl/view/

Version-Release number of selected component (if applicable):
F18-Beta-TC9
F18-Beta-TC8

F18-Beta-TC7 is correct -- selecting Dutch gives the Dutch translation.

How reproducible:
Always.

Steps to Reproduce:
1. Select Dutch as the install language.
  
Actual results:
Polish translation.

Expected results:
Dutch translation.

Additional info:
Comment 1 Steve Tyler 2012-11-16 22:44:59 EST
Proposing F18-Beta Blocker NTH, F18-Final Blocker per:

15. All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use 

Fedora 18 Final Release Criteria
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 2 Steve Tyler 2012-11-17 11:46:51 EST
There appear to be a few Dutch strings in the translation:
"Voltooi partitioneren"
"opslagapparaat geselecteerd"

After completing an install with Dutch selected as the install language, the locale string is for Dutch. /etc/locale.conf and /etc/sysconfig/i18n have:
LANG="nl_NL.UTF-8"

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-1.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC9/Fedora-18-Beta-TC9-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 3 Kamil Páral 2012-11-19 08:44:52 EST
*** Bug 877923 has been marked as a duplicate of this bug. ***
Comment 4 Kamil Páral 2012-11-19 08:50:25 EST
When looking into Transifex (the link in description), this is not a problem in anaconda. The transifex itself contains polish strings for dutch localization. Some translator probably messed it up.

Does anyone knows where to re-assign this bug report?
Comment 5 Steve Tyler 2012-11-19 11:40:36 EST
Thanks for assigning this bug to the right component: Dutch [nl].

The pl strings seem to have been added as far back as 2011-01-29:

before:2011-01-28   no strings
before:2011-01-29   pl strings

You can do some date filtering at Transifex by entering queries like these in the search box:

    "before:YYYY-MM-DD"
    "after:YYYY-MM-DD"

https://fedora.transifex.com/projects/p/anaconda/resource/master/l/nl/view/
Comment 6 Adam Williamson 2012-11-19 11:55:42 EST
Discussed at 2012-11-19 QA meeting, acting as an NTH review meeting. Accepted as NTH, this affects translations during install, would be a safe fix and can't be fixed with an update.
Comment 7 Steve Tyler 2012-11-23 12:26:18 EST
A Polish translation was added to the Dutch database as recently as:
after:2012-11-09

Further, the Polish translation appears to have been updated at the same time. Specifically:

"Click here to create them automatically."
"Kliknięcie tutaj utworzy je automatycznie."

https://fedora.transifex.com/projects/p/anaconda/resource/master/l/nl/view/
https://fedora.transifex.com/projects/p/anaconda/resource/master/l/pl/view/
Comment 8 Steve Tyler 2012-11-23 16:01:55 EST
Piotr: I added you to the CC list, because it looks like Polish translations are being uploaded to the Dutch translation for anaconda, and you appear to be maintaining the Polish translations. Is the translator aware of this problem?
Comment 9 Piotr Drąg 2012-11-24 08:59:00 EST
I'm not sure why this happened, but I have never touched Dutch translation (and I'm the only Polish translator). It must have been a wrong merge or something. Maybe we should file a bug in upstream Transifex?

FWIW f17-branch in Transifex is actually master (f18) branch from 3 months ago, so maybe we could use Dutch translation from there to restore as much translations as we can.
Comment 10 Tim Flink 2012-11-30 13:39:47 EST
+1 final blocker due to violation of the following F18 final release criterion [1]:

All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use

[1] http://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 11 Steve Tyler 2012-11-30 13:58:42 EST
Geert: I'm adding you to the CC list, because you appear to be the Dutch translator for anaconda. Most of the Dutch translation in master is Polish. Could you confirm that?
Comment 12 Geert Warrink 2012-11-30 15:38:51 EST
I am the dutch translator of Anaconda.
I noticed Tuesday when I installed Fedora 18b on my laptop that the translation is Polish. I checked Transifex and there also was the Ducth translation overwritten by Plolish. I have no idea how this could happen. I have made help request at Transifex (#1577), but until now I have not yet received an answer.
The last few weeks I have translated a few strings when anaconde was updated in Transifex, so there are indeed a few Dutch string in the translation.
I am not sure how to proceed, as I have on my computer no backup of the Dutch translation of anaconda. I don't know if Transifex can provide me a backup.
I'm eagerly waiting for ther response. If no help can be given, I'll just start the translation from scratch.
Comment 13 Geert Warrink 2012-11-30 15:44:28 EST
I see now in the Bug Header that this bug is assigned to Bart Couvreur.
As far as I know he is not active anymore with Dutch translations. I'm now the Dutch coordinator. Has somewhere a change to be made to make sure that this kind of bugs are reported directly to me?
Comment 14 Piotr Drąg 2012-11-30 16:29:49 EST
(In reply to comment #13)
> I see now in the Bug Header that this bug is assigned to Bart Couvreur.
> As far as I know he is not active anymore with Dutch translations. I'm now
> the Dutch coordinator. Has somewhere a change to be made to make sure that
> this kind of bugs are reported directly to me?

Done.

http://git.fedorahosted.org/cgit/l10n/owners.git/commit/?id=cfc78679be228f599203c8d248af0c1abae2004e

As for lost translation, see my comment #9, maybe it could help.
Comment 15 Adam Williamson 2012-12-01 01:23:56 EST
surely transifex should be using some kind of rcs system?! I know nothing about it, but I can't imagine a system like that today wouldn't.
Comment 16 Adam Williamson 2012-12-01 03:15:20 EST
I'm -1 on this, the point of the criterion is that the installer should display available translations. Well it's displaying the available translation, it's the translation that's wrong. I don't think we should block the release for one broken translation, though obviously we should fix it...
Comment 17 Steve Tyler 2012-12-01 07:20:16 EST
"The objective of the Final release is to:

1. Provide a polished final release suitable for meeting the needs of our Target Audience"
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria

Also, this bug cannot be fixed with an update.

The fundamental problem is that Dutch users will need to be able to read Polish while installing, if they want the locale set to nl_NL[1] when installation is complete. The alternative is to install in another language and then change the language to Dutch from the installed system.

[1] /usr/share/i18n/locales/nl_NL
Comment 18 Geert Warrink 2012-12-01 15:07:00 EST
I'm recontructing the Dutch translation of anaconda at this moment using the F17 version. I expect to finalize this tomorrow.
Comment 19 Steve Tyler 2012-12-01 15:47:41 EST
Thanks for your update, Geert. And thanks for your help, Piotr.

It might be a good idea to see if the problem can be reproduced by doing a test translation of a single string and seeing where it goes ...
Comment 20 Geert Warrink 2012-12-02 09:03:38 EST
The Dutch translation for anaconda is now finished and available on Transifex.
Comment 21 Kevin Fenzi 2012-12-04 18:55:34 EST
Great work. ;) I'm -1 blocker, but +1 NTH. 

Since it's already fixed, hopefully it will be easy to pull before we even freeze for final.
Comment 22 Robyn Bergeron 2012-12-04 22:37:37 EST
-1 blocker, +1 NTH, for reasons adam listed above (if it was anaconda actually fouling up I would be more on the side of blocker per the criteria)

That said; while Geert awesomely did a new translation, I'm concerned that it seems to have just gone awry on its own, and that we haven't figured out the source of that issue (unless that ticket has made progress recently), and have concerns that it could oddly happen again...
Comment 23 Steve Tyler 2012-12-04 23:13:10 EST
There are some new anaconda strings to be translated, including "Installing bootloader". This might be a good opportunity to see if the problem can be reproduced:

Variant 1:
1. Upload a Polish translation of "Installing bootloader".
2. See if the Polish translation appears in the Dutch translation.

Variant 2:
1. Upload a Dutch translation of "Installing bootloader".
2. Upload a Polish translation of "Installing bootloader".
3. See if the Polish translation replaces the Dutch translation.

https://fedora.transifex.com/projects/p/anaconda/resource/master/l/nl/view/
https://fedora.transifex.com/projects/p/anaconda/resource/master/l/pl/view/
Comment 24 Geert Warrink 2012-12-05 04:57:38 EST
I received a reaction from Transifex concerning the anaconda situation.
A citation from this:

..."The history shows that the Polish translations were done by some other user. This makes me think that if a Polish translation file was uploaded for the Dutch translation by mistake. We are looking into this to check whether this was due to any issue at our end. If it is, we'll ensure that this does not get repeated in the future."...

So I think for the moment we don't need to do any testing.
Comment 25 Jóhann B. Guðmundsson 2012-12-05 06:58:43 EST
-1 blocker, +1 NTH
Comment 26 Tim Flink 2012-12-05 10:17:50 EST
Changing my vote to -1 blocker, +1 nth as well. It doesn't make sense to block release over one translation and it sounds like it'll be fixed in time.

That makes -4 blocker, +4 NTH - moving to rejected blocker and accepted nth
Comment 27 Steve Tyler 2012-12-05 13:39:56 EST
Thanks, Geert.[1] I agree that we can wait for a final report from Transifex.

Do you have a link to the ticket you opened[2]? I couldn't find any publicly accessible bug tracking links at http://support.transifex.com.

[1] Comment 24.
[2] Comment 12.
Comment 28 Piotr Drąg 2012-12-05 14:25:58 EST
(In reply to comment #23)
> There are some new anaconda strings to be translated, including "Installing
> bootloader". This might be a good opportunity to see if the problem can be
> reproduced:
> 
> Variant 1:
> 1. Upload a Polish translation of "Installing bootloader".
> 2. See if the Polish translation appears in the Dutch translation.
> 

FWIW I've just translated 12 new strings in Polish translation, including such ones as "Installing bootloader", "Configuring installed system" or "Writing network configuration", could you please test if they appeared in Dutch translation?
Comment 29 Steve Tyler 2012-12-05 14:44:30 EST
Thanks, Piotr. It looks like Geert also translated those strings.

Transifex lets you search by date:
after:2012-12-05

Dutch:  Showing 1 to 12 of 12 entries
https://fedora.transifex.com/projects/p/anaconda/resource/master/l/nl/view/

Polish: Showing 1 to 12 of 12 entries
https://fedora.transifex.com/projects/p/anaconda/resource/master/l/pl/view/
Comment 30 Geert Warrink 2012-12-05 15:43:35 EST
I checked the Dutch translation after the Polish update and found no problems in the Dutch translation. So transifex seems to be ok now.

When I go to http://support.transifex.com/requests, I see a page with my open request with number #1577. I'm not sure if transifex has a publicly accesable tracking.
Comment 31 Geert Warrink 2012-12-05 15:59:17 EST
Steve,
Does http://support.transifex.com/requests/1577 work for you?
Comment 32 Steve Tyler 2012-12-05 16:07:03 EST
(In reply to comment #31)
> Steve,
> Does http://support.transifex.com/requests/1577 work for you?

Thanks for the link. That redirects to a login page:

Log in to Transifex Help Desk
http://support.transifex.com/access/unauthenticated?return_to=http%3A%2F%2Fsupport.transifex.com%2Frequests%2F1577

Maybe registration is required to view it ...
Comment 33 info@kobaltwit.be 2013-08-10 12:05:24 EDT
Is this an issue still ? Or did you forget to close the bug ?
Comment 34 Steve Tyler 2013-08-10 12:37:34 EDT
The F19 DVD appears to show Dutch, except for a few strings that appear in English.

Geert: Could you confirm that the F19 installer images show Dutch when Dutch is selected as the install language?

Also, did you ever get a response from transifex (Comment 12, Comment 30)?

Tested in a VM with:
$ qemu-kvm -m 4096 -hda f19-test-2.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
Comment 35 Geert Warrink 2013-08-10 12:53:12 EDT
I tested a fresh Dutch installation for Fedora 19 on my laptop and found no problems. I did receive a response from transifex with an apology, but no further details on how the Polish translation could have overwritten the Dutch translation. In all my further work in transifex I never met this problem again.

I will colse the bug.
Comment 36 Steve Tyler 2013-08-10 13:27:05 EDT
Thanks, Geert. It would be better to set the resolution to CURRENTRELEASE, I think ...