Bug 877658

Summary: [i18n] some storage-related error messages not marked for translation: "Not enough free space on disks for automatic partitioning"
Product: [Fedora] Fedora Reporter: Steve Tyler <stephent98>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: anaconda-maint-list, awilliam, g.kaviyarasu, jonathan, kparal, piotrdrag, robatino, sbueno, stephent98, vanmeeuwen+fedora, vpodzime
Target Milestone: ---Keywords: i18n, Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: anaconda-18.37.9-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-03 21:32:50 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752661, 858628    
Attachments:
Description Flags
screenshot showing untranslated string "Not enough free space on disks for automatic partitioning"
none
screenshot showing untranslated strings "Remove" and "Close"
none
screenshot showing "DATE & TIME" not translated
none
screenshot showing "KEYBOARD" not translated
none
screenshot showing "not enough free space on disks" not translated
none
screenshot showing that both spoke titles and category names are shown translated none

Description Steve Tyler 2012-11-17 12:38:34 EST
Created attachment 646852 [details]
screenshot showing untranslated string "Not enough free space on disks for automatic partitioning"

Description of problem:
This string is not translated:
"Not enough free space on disks for automatic partitioning"
See attached screenshot.

Version-Release number of selected component (if applicable):
anaconda-18.29-1
Fedora-18-Beta-TC9-x86_64-Live-Desktop.iso

How reproducible:
Always.

Steps to Reproduce:
1. Select Spanish as the install language.

NB: Transifex shows 100% translation coverage for Spanish:
https://fedora.transifex.com/projects/p/fedora/language/es/?project=2059
  
Actual results:
Some strings are not translated.
See attached screenshot.

Expected results:
All strings are translated.

Additional info:
$ grep -rl 'automatic partitioning' anaconda-18.29-1/
anaconda-18.29-1/pyanaconda/storage/partitioning.py
anaconda-18.29-1/pyanaconda/ui/gui/spokes/custom.py
anaconda-18.29-1/anaconda.spec.in

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-1.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC9/Fedora-18-Beta-TC9-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 1 Steve Tyler 2012-11-17 13:35:06 EST
Created attachment 646899 [details]
screenshot showing untranslated strings "Remove" and "Close"
Comment 2 Steve Tyler 2012-11-17 13:58:46 EST
(In reply to comment #1)
> Created attachment 646899 [details]
> screenshot showing untranslated strings "Remove" and "Close"

$ egrep 'Remove|Close' anaconda-18.29-1/po/anaconda.pot
msgid "_Remove Packages"
msgid "Closest mirror"
msgid "Remove layout"
msgid "Remove the selected mountpoint(s.)"
msgid "Close"

The screenshot also shows that "INSTALLATION DESTINATION" and "Done" are untranslated. Transifex shows them as being translated, however:

$ egrep 'INSTALLATION DESTINATION|Done' anaconda-18.29-1/po/anaconda.pot
msgid "You have provided a weak password: %s.  Press Done again to use anyway."
msgid "INSTALLATION DESTINATION"
msgid "_Done"
Comment 3 Steve Tyler 2012-11-17 14:04:45 EST
More untranslated strings:

INSTALLATION SUMMARY
Quit
DATE & TIME
KEYBOARD
MANUAL PARTITIONING
Comment 4 Steve Tyler 2012-11-17 14:24:37 EST
(In reply to comment #3)
> More untranslated strings:
> 
> INSTALLATION SUMMARY
> Quit
> DATE & TIME
> KEYBOARD
> MANUAL PARTITIONING

Transifex shows these are all translated:[1]

$ egrep 'INSTALLATION SUMMARY|Quit|DATE & TIME|KEYBOARD|MANUAL PARTITIONING' anaconda-18.29-1/po/anaconda.pot | sort
msgid "ADD A KEYBOARD LAYOUT"
msgid "DATE & TIME"
msgid "INSTALLATION SUMMARY"
msgid "KEYBOARD"
msgid "KEYBOARD LAYOUT"
msgid "MANUAL PARTITIONING"
msgid "_Quit"
msgid "_Quit installer"

[1] https://fedora.transifex.com/projects/p/anaconda/resource/master/l/es/view/
Comment 5 Steve Tyler 2012-11-17 14:34:36 EST
Created attachment 646937 [details]
screenshot showing "DATE & TIME" not translated
Comment 6 Steve Tyler 2012-11-17 14:35:41 EST
Created attachment 646938 [details]
screenshot showing "KEYBOARD" not translated
Comment 7 Steve Tyler 2012-11-17 16:34:49 EST
Created attachment 646992 [details]
screenshot showing "not enough free space on disks" not translated
Comment 8 Steve Tyler 2012-11-18 14:35:09 EST
It looks like Bug 858628 is supposed to be tracking the translated-but-still-displayed-in-English problem. Restoring original summary for these two untranslated strings:

"Not enough free space on disks for automatic partitioning"
"not enough free space on disks"

$ grep -n 'enough' anaconda-18.29-1/po/anaconda.pot 
35:msgid "Not enough RAM"
157:"%s may not have enough space for grub2 to embed core.img when using the %s "
842:"do not have enough available.  You can change your selections or exit the "
1799:msgid "Not enough free space on selected disks."
2190:"<b>You don't have enough space available to install %s</b>, but we can help "
2199:"You don't have enough space available to install <b>%s</b>, even if you used "
2207:"<b>You don't have enough space available to install %s</b>, even if you used "
2337:"You don't have enough free space available for this installation.\n"
Comment 9 Steve Tyler 2012-12-17 15:05:35 EST
Some storage-related error messages have not been marked for translation.[1]

Examples:
$ grep -rl 'enough free space' anaconda-18.37.3-1/pyanaconda/storage/
anaconda-18.37.3-1/pyanaconda/storage/partitioning.py
anaconda-18.37.3-1/pyanaconda/storage/devices.py
anaconda-18.37.3-1/pyanaconda/storage/__init__.py

Revising summary.

[1] https://fedora.transifex.com/projects/p/anaconda/resource/master/l/en/view/
Comment 10 Steve Tyler 2012-12-17 15:35:14 EST
Proposing as F18 Final blocker per proposed release criterion:

"All error messages intended for users are marked for translation."

1. Error messages are particularly important to have translated, because they report unusual or unexpected situations.
2. Cannot be fixed with an update.

The release criterion for translations presupposes that strings have been correctly marked for translation:

14. All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use 

https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 11 Vratislav Podzimek 2012-12-18 08:32:36 EST
Chris, is there any reason why we have spoke titles, category names and some other stuff marked only with N_() ? I could fix this bug, but it seems to me that there must have been some reason for N_() instead of _().
Comment 12 Chris Lumens 2012-12-18 10:37:07 EST
(In reply to comment #11)
> Chris, is there any reason why we have spoke titles, category names and some
> other stuff marked only with N_() ? I could fix this bug, but it seems to me
> that there must have been some reason for N_() instead of _().

Likely just an artifact of how I started doing development on this.  Anyway spoke titles and category titles should all be translated properly with bb41f4f4d4747572de58eda3be68e2189beebd0f, or some of the commits right around it.

This is yet another one of those catch-all "something isn't translated, so I'm going to pile it into this one bug report" bugs.  Please ignore everything except partitioning error messages.
Comment 13 Vratislav Podzimek 2012-12-19 04:17:21 EST
Created attachment 665988 [details]
screenshot showing that both spoke titles and category names are shown translated

Indeed, spoke titles and category names are shown translated. I'll have a look at the storage messages.
Comment 14 Adam Williamson 2012-12-19 12:22:46 EST
Discussed at 2012-12-19 blocker review meeting. Accepted as a blocker per criterion "All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use" (this is read to include installation, though we should probably state that explicitly).
Comment 15 Vratislav Podzimek 2012-12-21 05:40:10 EST
Two patches posted to anaconda-patches. I'm on a PTO today, but I hope Brian or somebody else will git-am them for the next F18 build.
Comment 16 Fedora Update System 2012-12-21 18:32:14 EST
dracut-024-17.git20121220.fc18, anaconda-18.37.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-20838/dracut-024-17.git20121220.fc18,anaconda-18.37.7-1.fc18
Comment 17 Fedora Update System 2012-12-21 18:32:21 EST
dracut-024-17.git20121220.fc18, anaconda-18.37.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-20838/dracut-024-17.git20121220.fc18,anaconda-18.37.7-1.fc18
Comment 18 Fedora Update System 2012-12-22 16:10:44 EST
Package dracut-024-17.git20121220.fc18, anaconda-18.37.8-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-024-17.git20121220.fc18 anaconda-18.37.8-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20838/dracut-024-17.git20121220.fc18,anaconda-18.37.8-1.fc18
then log in and leave karma (feedback).
Comment 19 Kamil Páral 2013-01-02 08:53:21 EST
"Not enough free space on disks for automatic partitioning" is still untranslated in Spanish in anaconda-18.37.8. Also "failed to create device". But we may need to wait for another build, so that the new translations can be pulled from transifex.
Comment 20 Fedora Update System 2013-01-02 16:49:11 EST
dracut-024-17.git20121220.fc18, anaconda-18.37.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Kamil Páral 2013-01-03 04:25:46 EST
We need TC4 to verify this, reopening.
Comment 22 Kamil Páral 2013-01-03 07:50:19 EST
"Not enough free space on disks for automatic partitioning" is still untranslated in Italian (which has 100% translation coverage from Dec 30) in TC4. But anaconda-18.37.8 is from Dec 22, so we need a new anaconda build to include all the latest translations in order to check this is fixed.
Comment 23 Adam Williamson 2013-01-03 21:29:52 EST
Looks fixed with https://admin.fedoraproject.org/updates/anaconda-18.37.9-1.fc18 . bcl, can you mark the update as fixing this bug?
Comment 24 Adam Williamson 2013-01-03 21:32:50 EST
kamil: the bug is in the string being marked for translation, not in whether the translation is present. I tested and it is fixed wrt Spanish, the original test language, in TC4: so closing.
Comment 25 Kamil Páral 2013-01-04 04:04:24 EST
Adam: I know, it's just impossible to verify if there is no translation to test with. That's why I was waiting for another anaconda build before closing this. With today's 18.37.9 it's finally possible to verify it. Thanks for doing that.