This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 877940

Summary: [ALL_LANG][SAM Web GUI] Some unlocalized strings for uploading and deleting a manifest.
Product: Red Hat Satellite 6 Reporter: Lijun Li <lijli>
Component: Content ManagementAssignee: Katello Bug Bin <katello-bugs>
Status: CLOSED WONTFIX QA Contact: SAM QE List <sam-qe-list>
Severity: medium Docs Contact:
Priority: medium    
Version: NightlyCC: agarcia, eng-l10n-bugs, hpeters, qe-i18n-bugs, sfriedma, tomckay, ypoyarko
Target Milestone: UnspecifiedKeywords: i18n, Translation, Triaged
Target Release: 6.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-08 14:45:33 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Unlocalized strings for uploading and deleting a manifest none

Description Lijun Li 2012-11-19 04:58:07 EST
Description of problem:
Some unlocalized strings for uploading and deleting a manifest:
Upload New Manifest
(waiting)
(runnig)
Subscription manifest uploaded successfully for provider 'Red Hat'. 
Upstream Distributor
Delete Manifest
Limits
Stacking ID
Consumed
Deleting a manifest will permanently remove all current subscriptions. All systems consuming these subscriptions have them removed. Do you wish to proceed with removing this manifest?

Version-Release number of selected component (if applicable):
katello-headpin-all-1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Click the Content application tab.
2. Move cursor over the Subscriptions menu at the left corner and click on Red Hat Subscriptions.
3. Click the +Import Manifest button.
4. On the Subscription Manifest - Import tab, click the Browse button to specify the location of the manifest.
5. Click the Upload button to upload subscription manifest.
6. Click the +Import Manifest button.
7. Click the Delete Manifest button to delete the subscription manifest.
  
Actual results:
Some unlocalized strings for uploading and deleting a manifest:
Upload New Manifest
(waiting)
(runnig)
Subscription manifest uploaded successfully for provider 'Red Hat'. 
Upstream Distributor
Delete Manifest
Limits
Stacking ID
Consumed
Deleting a manifest will permanently remove all current subscriptions. All systems consuming these subscriptions have them removed. Do you wish to proceed with removing this manifest?

Expected results:
All strings for uploading and deleting a manifest should be localized.

Additional info:
Comment 1 Lijun Li 2012-11-19 05:00:19 EST
Created attachment 647644 [details]
Unlocalized strings for uploading and deleting a manifest
Comment 2 Yulia 2012-12-12 20:54:35 EST
Russian: When trying to upload some random file as manifest, partially translated error message appears.

    malformed format string (ArgumentError)
    Click here для получения информации.

Could not find "malformed format string" in SAM-1.2.po file
Comment 3 Hedda Peters 2012-12-12 22:48:52 EST
Uploading a manifest file failed for de-DE QE test, but the resulting error message is also unlocalized:

Subscription manifest upload for provider 'Red Hat' failed.
Reason: Import is the same as existing data
Resources::Candlepin::Owner: 409 Conflict {"displayMessage":"Import is the same as existing data","conflicts":["MANIFEST_SAME"]} (POST /candlepin/owners/ACME_Corporation/imports) (RestClient::Conflict)
{"displayMessage":"Import is the same as existing data","conflicts":["MANIFEST_SAME"]}
Comment 4 Sam Friedmann 2012-12-13 01:24:46 EST
Same with French (as Hedda's comment).
Comment 5 Lijun Li 2012-12-13 05:12:43 EST
*** Bug 886739 has been marked as a duplicate of this bug. ***
Comment 6 Tom McKay 2012-12-18 09:24:25 EST
Mass move of i18n to CFSE where they are present as well
Comment 8 Bryan Kearney 2014-01-08 14:45:33 EST
Closing all L10N bugs until we can do a full translation path through the code.