This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 877997

Summary: vdr-1.7.38 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: vdrAssignee: Ville Skyttä <ville.skytta>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dnehring, ville.skytta, vpvainio
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: vdr-1.7.38-1 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-20 14:04:21 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 909946    

Description Upstream Release Monitoring 2012-11-19 06:57:00 EST
Latest upstream release: 1.7.32
Current version in Fedora Rawhide: 1.7.31
URL: ftp://ftp.tvdr.de/vdr/Developer/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Ville Skyttä 2012-11-20 13:51:50 EST
Waiting for availability of the hard link cutter patch for 1.7.32 (upstream pinged).
Comment 2 Ville Skyttä 2012-12-10 13:03:55 EST
*** Bug 885461 has been marked as a duplicate of this bug. ***
Comment 3 Ville Skyttä 2012-12-26 10:34:43 EST
*** Bug 890026 has been marked as a duplicate of this bug. ***
Comment 4 Dirk Nehring 2012-12-26 18:40:41 EST
I don't think the hard link cutter will be ported to 1.7.32+ in the near future. I am sure if this patch should be a showstopper since today most disks a big enough to handle the data.
For me, I don't like the file splitting at 4 GB or even much smaller sizes (I use 16 GB+ and I do not need FAT32 compatiblity), so this patch is nearly useless to me.

kls implements some enhancements in the cutter code in 1.7.32 and 1.7.33 which should be in this release (dropping dangling packets, fixes timestamps, fixes  continuity counters, ...).

Instead I vote for a patch to remove the NALU12 data.
Comment 5 Ville Skyttä 2012-12-27 04:20:20 EST
*** Bug 890026 has been marked as a duplicate of this bug. ***
Comment 6 Ville Skyttä 2012-12-27 04:28:59 EST
The 1.7.x series versioning incompatibility issues alone are pretty much a showstopper as far as updating F-18 or earlier is concerned, no matter what happens to hlcutter.

As someone who uses hard link cutting a lot and knows its advantages first hand very well, I won't consider shipping an update to F-18 or earlier that drops it, that'd be a big regression. Disk or recording sizes are not relevant; it's a matter of recording cutting taking a few seconds (with hard link cutter) vs a *lot* longer time.

I don't know how the NALU12 thing is related to this issue. Maybe it should be tracked in another new bug?
Comment 7 Ville Skyttä 2012-12-31 10:45:58 EST
*** Bug 890991 has been marked as a duplicate of this bug. ***
Comment 8 Ville Skyttä 2013-01-21 06:13:49 EST
*** Bug 902254 has been marked as a duplicate of this bug. ***
Comment 9 Ville Skyttä 2013-02-11 13:09:32 EST
*** Bug 909945 has been marked as a duplicate of this bug. ***
Comment 10 Dirk Nehring 2013-02-20 17:39:45 EST
Great! I vote for inclusion into F18!
Comment 11 Ville Skyttä 2013-02-21 09:35:06 EST
(In reply to comment #10)
> I vote for inclusion into F18!

Most likely won't happen due to ABI/API incompatibilities, and there are still the jumpplay and hard link cutter regressions to solve, VDR 2.0 with another ABI incompatibility around the corner etc.

Besides, for those who want a newer version, the rawhide VDR packages can at least currently be run on F-18 as is, that's what my VDR setup does: IIRC enable the rawhide repo, and add includepkgs=vdr* to its config so other unwanted rawhide stuff won't sneak in.