Bug 878956

Summary: After installation is complete, Alt+F4 is broken
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: xorg-x11-serverAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: ajax, apatil, awilliam, g.kaviyarasu, jonathan, jwboyer, mfabian, robatino, rubs33, sbueno, tfujiwar, vanmeeuwen+fedora, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedNTH RejectedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-06 02:20:04 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 752665    
Attachments:
Description Flags
bug demonstration video none

Description Kamil Páral 2012-11-21 11:20:44 EST
Created attachment 649297 [details]
bug demonstration video

Description of problem:
After the installation is complete, the system behaves like Ctrl was always pressed. You can use Alt+F4 to close an application, because it switches you to tty4 (like Ctrl+Alt+F4 would do). (But the application is closed after you return back to tty1). If you hit Alt+F2, you are switched to tty2, but gnome-shell's "run command" dialog appears.

This doesn't happen after the system is booted or when the installation is underway. Only after the installation is complete. (I forgot to test what happens when I close Anaconda window, that I do not know).

This is problematic when a user doesn't know what VT is and how to get back to graphical console. He might be forced to hard-reset the machine. It might also look the the installer/system crashed.

Version-Release number of selected component (if applicable):
anaconda 18.29.2
F18 Beta RC1 Live

How reproducible:
always

Steps to Reproduce:
1. boot Live
2. finish installation
3. try to close some other application with Alt+F4
Comment 1 Kamil Páral 2012-11-21 11:22:53 EST
I believe this should be a F18 Blocker, because it can't be fixed with an update and it might create a lot of problems and confusions for Fedora LiveCD users.

Use case:
Working with LiveCD and installing in the background. After the installation is complete, I want to close existing windows (browser, chat, etc) -> Alt+F4 -> tty4.
Comment 2 Rubens Takiguti Ribeiro 2012-11-27 18:16:33 EST
I noticed the same bug using the live cd (Fedora-18-Beta-x86_64-Live-Desktop.iso). So, the problem should not be at anaconda.

Description: the Ctrl key appers to be pressed automatically when the Alt key is pressed.

Minimum steps to reproduce the bug:
1 - starts user session using live cd.
2 - click on "Live System User" menu.
3 - click on "System Settings" option.
4 - click on "Region & Settings" option.
5 - click on "System" tab.
6 - click on "Copy Settings..." button.

--

Note:

before step 6, the System tab was like that:
* Your settings
  - Display language: English (United States)
  - Input source: English (US)
  - Format: United States (Enlish)
* System settings:
  - Display language: English (United States)
  - Input source: [none]
  - Format: United States (English)

after step 6, the System tab was like that:
* Your settings
  - Display language: English (United States)
  - Input source: English (US)
  - Format: United States (Enlish)
* System settings:
  - Display language: English (United States)
  - Input source: English (US)
  - Format: United States (English)
Comment 3 Kamil Páral 2012-11-28 07:23:21 EST
Great findings, Rubens! Thanks.

This is tightly connected to Anaconda, because this bug does not shown before "Configuring installed system" phase in Anaconda. After that phase is over, this bug manifests. If you check Region&Language afterwards, it contains the same output as you stated in comment 2 after step 6. That means Anaconda performs the exact procedure that you did manually and triggers this bug.

I checked also KDE LiveCD and this problem manifests as well. Before Anaconda installation is complete, Alt+F2 shows "run command" dialog, after it is over (and language preferences are adjusted), it switches to tty2.

The problem must be somewhere in Xorg or other low-level tools. Reassigning.

systemd-195-8.fc18.i686
systemd-libs-195-8.fc18.i686
systemd-sysv-195-8.fc18.i686
xorg-x11-drv-ati-7.0.0-0.6.20120910git7c7f27756.fc18.i686
xorg-x11-drv-evdev-2.7.3-2.fc18.i686
xorg-x11-drv-fbdev-0.4.3-3.fc18.i686
xorg-x11-drv-geode-2.11.13-4.fc18.i686
xorg-x11-drv-intel-2.20.12-1.fc18.i686
xorg-x11-drv-mga-1.6.1-2.fc18.i686
xorg-x11-drv-modesetting-0.4.0-4.fc18.i686
xorg-x11-drv-nouveau-1.0.3-1.fc18.i686
xorg-x11-drv-openchrome-0.3.1-1.fc18.i686
xorg-x11-drv-qxl-0.0.22-5.20120718gitde6620788.fc18.i686
xorg-x11-drv-synaptics-1.6.2-5.fc18.i686
xorg-x11-drv-vesa-2.3.2-2.fc18.i686
xorg-x11-drv-vmmouse-12.9.0-7.fc18.i686
xorg-x11-drv-vmware-12.0.2-3.20120718gite5ac80d8f.fc18.i686
xorg-x11-drv-wacom-0.16.1-2.fc18.i686
xorg-x11-font-utils-7.5-9.fc18.i686
xorg-x11-server-common-1.13.0-7.fc18.i686
xorg-x11-server-utils-7.5-13.fc18.i686
xorg-x11-server-Xorg-1.13.0-7.fc18.i686
xorg-x11-utils-7.5-7.fc18.i686
xorg-x11-xauth-1.0.7-2.fc18.i686
xorg-x11-xinit-1.3.2-7.fc18.i686
xorg-x11-xkb-utils-7.7-4.fc18.i686
Comment 4 Rubens Takiguti Ribeiro 2012-11-28 11:28:02 EST
Kamil,
Based on the bug nature, I suppose the problem may be at new IBUS features:
https://fedoraproject.org/wiki/Features/GNOMEIBusIntegration
https://fedoraproject.org/wiki/Features/Typing-Booster
Comment 5 Adam Williamson 2012-11-28 12:30:03 EST
I suspect this may be related somehow to https://bugzilla.redhat.com/show_bug.cgi?id=859485 . Josh, Adam, is that the case?
Comment 6 Josh Boyer 2012-11-28 12:34:11 EST
(In reply to comment #5)
> I suspect this may be related somehow to
> https://bugzilla.redhat.com/show_bug.cgi?id=859485 . Josh, Adam, is that the
> case?

Sounds likely.  Particularly the steps from comment #2.

A kernel fix is already available.  We're waiting on a patched Xorg.
Comment 7 Adam Williamson 2012-11-28 12:48:56 EST
Discussed at 2012-11-28 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-28/f18final-blocker-review-1.2012-11-28-16.59.log.txt . Agreed this is rejected as a blocker - it's an annoying bug, but it doesn't quite hit any of the criteria, and we didn't think it ultimately passed the 'if today was go/no-go and this was the last bug, would we slip?' smell test. It is accepted as NTH as it's a significant user experience bug that cannot be fixed with an update.
Comment 8 Fedora Update System 2012-11-28 13:39:54 EST
xorg-x11-server-1.13.0-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.13.0-10.fc18
Comment 9 Fedora Update System 2012-11-28 16:13:42 EST
Package xorg-x11-server-1.13.0-10.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.13.0-10.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19315/xorg-x11-server-1.13.0-10.fc18
then log in and leave karma (feedback).
Comment 10 Kamil Páral 2012-11-29 04:44:22 EST
Because I can't simulate the problem on an installed system, I have tested xorg-x11-server-1.13.0-10.fc18 by updating it on LiveCD, restarting gdm a following the reproducer. The bug still happens. Do I also need updated kernel to verify this?
Comment 11 Josh Boyer 2012-11-29 08:02:11 EST
What kernel is on the livecd?  If it isn't 3.6.7-5.fc18 or newer, then yes you need a newer kernel.
Comment 12 Kamil Páral 2012-11-29 14:27:38 EST
This is fixed with kernel 3.6.7-5.fc18 and xorg-x11-server-1.13.0-10.fc18. I built a custom LiveCD and checked.
Comment 13 Fedora Update System 2012-11-30 14:56:42 EST
xorg-x11-server-1.13.0-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.13.0-11.fc18
Comment 14 Fedora Update System 2012-12-06 02:20:07 EST
xorg-x11-server-1.13.0-11.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.