Bug 87933

Summary: Installer crashes on a system with AIC-7899 and AMI MegaRAID
Product: [Retired] Red Hat Linux Reporter: Rajkumar S <reactos>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED WONTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-30 15:40:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
Anaconda Dump none

Description Rajkumar S 2003-04-03 20:09:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:

I am installing RH-8 on a Wipro Netpower computer which has an Adaptec AIC-7889
(v 2.57) and AMI MegaRAID 40-LD (v 3.11). While installation anaconda reaches
till partition stage and says that the partition table in sda is inconsistant
and it needs to recreate it. I said OK and proceeded to Disk Druid and here
anaconda bombs with the attached trace.  Next time I tried to partition with
fdisk. fdisk was able to partition the disk, but after exiting from fdisk
anaconda again complainted that the partition table is bad, with same results. I
have attached the full dump.


Comment 1 Rajkumar S 2003-04-03 20:13:08 UTC
Created attachment 90880 [details]
Anaconda Dump

Comment 2 Rajkumar S 2003-04-06 17:54:26 UTC
more info,

I installed debian (woody) in that system from the second CD. The issue seems to
be more like a kernel one. The stock debian kernel works fine, but when I tried
to put my own 2.4.20 in that the kernel panicked 'coz it could not find mount
the root. Just before that it gave an error on the lines that partition table in
sda is inconsistant, similar to the one given by anaconda. 

I will be investigating more about this and will post the details here!


Comment 3 Rajkumar S 2003-04-07 17:38:36 UTC

Some more updates...

I tried debian on that system and it (woody) installed fine. That system was
going to be a pptp server, and to put in mppe I had to compile the kernel. I d/l
the latest 2.4 compiled with megaraid and aic7xxx driver. but that refused to
boot with the same error as the RH installer. At this point I got more
interested and got the debian 2.4 kernel, and the results were same. no boot.

So I got the 2.2.25 and compiled, and it worked fine!!

So this is not to do with the anaconda but with the kernel. That particular
device does not seems to work with 2.4 but works fine with 2.2. Usually it
happenes the other way round. 


Comment 4 Bugzilla owner 2004-09-30 15:40:44 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/