Bug 87934

Summary: mkinitrd forces SCSI host adapter detection order
Product: [Retired] Red Hat Linux Reporter: Chris Adams <linux>
Component: mkinitrdAssignee: Jeremy Katz <katzj>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-03 21:06:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
patch to /sbin/mkinitrd to remove alpha sorting of SCSI host adapters none

Description Chris Adams 2003-04-03 20:14:23 UTC
There is a "sort -u" when pulling the SCSI host adapter list from
/etc/modules.conf.  This means that the order the SCSI modules are loaded (if
you have more than one type of SCSI HA) is forced to be alphabetical, with no
way to override.

The "sort -u" is not needed to remove duplicate entries, as the findmodule()
function won't add a dupe.

This probably should only be changed in the next release, as it could affect
working setups that depend on the sort.  Or maybe, updating from a version that
doesn't sort to a version that does could sort the entries in /etc/modules.conf
and then leave them alone.

Anyway, suggested patch will be attached.

Comment 1 Chris Adams 2003-04-03 20:15:01 UTC
Created attachment 90881 [details]
patch to /sbin/mkinitrd to remove alpha sorting of SCSI host adapters

Comment 2 Jeremy Katz 2003-04-03 21:06:32 UTC
Look a little closer...  it sorts so that you get
scsi_hostadapter
scsi_hostadapter1
scsi_hostadapter2

instead of 
scsi_hostadapter1
scsi_hostadapter
scsi_hostadapter2

or something like that.  ie, the sort is on the whole string not the module name.

Comment 3 Chris Adams 2003-04-03 21:19:06 UTC
Yeah, sorry; I saw "grep scsi_hostadapter ..." and my mind saw 
grep "scsi_hostadapter " ...