Bug 879464

Summary: User process fault during firstboot run
Product: [Fedora] Fedora Reporter: IBM Bug Proxy <bugproxy>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 18CC: brueckner, gansalmon, itamar, jkachuck, jonathan, kernel-maint, madhu.chinakonda, wgomerin
Target Milestone: ---   
Target Release: ---   
Hardware: s390x   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-26 04:58:16 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description IBM Bug Proxy 2012-11-23 00:00:51 EST
Steps to recreate :
-------------------------------
1) Start F18 installation on a zVM guest
2) Go through various panels and screens to complete the installation.
3) On reboot login to the system via ssh with X11 forwarding

At this time first boot screen pops-up and then immediately killed. On the zVM console following messages are displayed.

[   97.496642] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[  187.198625] User process fault: interruption code 0x4003B in libcairo.so.2.11200.4[3fff575d000+11d000]
[  187.198640] failing address: 0
[  187.198642] Modules linked in: ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables iptable_nat nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack qeth_l3 qeth qdio ccwgroup dasd_eckd_mod dasd_mod
[  187.198671] CPU: 0 Not tainted 3.6.2-2.fc18.s390x #1
[  187.198674] Process python (pid: 1177, task: 000000003b43add0, ksp: 000000003d02ba00)
[  187.198677] User PSW : 0705e00180000000 000003fff57f4596 (0x3fff57f4596)
[  187.198684]            R:0 T:1 IO:1 EX:1 Key:0 M:1 W:0 P:1 AS:3 CC:2 PM:0 EA:3
User GPRS: 0000000000000031 0000000000000000 00000000ab9505c0 0000000100000000
[  187.198693]            000003ffff82a3f8 00000000ab9505c0 00000000ab9fd310 0000000000000013
[  187.198697]            00000000ffffffff 0000000000000000 00000000ab9fcc70 00000000ab9fb938
[  187.198830]            000003fffd456000 000003fff5846480 000003fff57f4578 000003ffff8296b0
[  187.198841] User Code: 000003fff57f4588: e340f0f00004	lg	%r4,240(%r15)
           000003fff57f458e: b9160038		llgfr	%r3,%r8
          #000003fff57f4592: a73b0001		aghi	%r3,1
          >000003fff57f4596: 58219000		l	%r2,0(%r1,%r9)
           000003fff57f459a: 5020f19c		st	%r2,412(%r15)
           000003fff57f459e: e320f19c001e	lrv	%r2,412(%r15)
           000003fff57f45a4: 50215000		st	%r2,0(%r1,%r5)
           000003fff57f45a8: a71b0004		aghi	%r1,4
[  187.198889] Last Breaking-Event-Address:
[  187.198891]  [<000003fffd3385ee>] 0x3fffd3385ee

# uname -a
Linux r3515043.boeblingen.de.ibm.com 3.6.2-2.fc18.s390x #1 SMP Wed Oct 17 16:53:57 EDT 2012 s390x s390x s390x GNU/Linux
# cat /etc/issue
Fedora release 18 (Spherical Cow)
Kernel \r on an \m (\l)

# cat /etc/redhat-release 
Fedora release 18 (Spherical Cow)
#

== Comment: #3 - SACHIN P. SANT <ssant@in.ibm.com> - 2012-11-14 02:43:27 ==
(In reply to comment #2)
> Is this reproducible? And on multiple systems? If so, do you think you could

Yes always. Have seen this on 2 systems.

> install the debug packages for Python during the install so that we might
> get a little better output?

Will try that.

> 
> Also - Does this only happen if you do the X11 forwarding?

Yes .. only when X11 is enabled. The libcairo.so is from package cairo-1.12.4-1.fc18.s390x. This package provides A 2D graphics library. May be other operations via a desktop might as well result in the same error.
Comment 1 Josh Boyer 2012-11-23 08:17:37 EST
*** Bug 879467 has been marked as a duplicate of this bug. ***
Comment 2 Josh Boyer 2012-11-23 08:17:54 EST
*** Bug 879468 has been marked as a duplicate of this bug. ***
Comment 3 IBM Bug Proxy 2012-12-04 03:40:27 EST
------- Comment From ssant@in.ibm.com 2012-12-04 08:32 EDT-------
With the latest build of F18 I can no longer recreate this problem.

There is a new version of Cairo package (cairo-1.12.8-1.fc18.s390x) which could be the reason.
Comment 4 Hendrik Brueckner 2013-02-26 04:58:16 EST
according to #c3, closing this bug.