Bug 879731

Summary: RFE: please make python3 pytz package for f18
Product: [Fedora] Fedora Reporter: Paulo Andrade <paulo.cesar.pereira.de.andrade>
Component: pytzAssignee: Jef Spaleta <jspaleta>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: amcnabb, jspaleta, limburgher
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-26 23:49:20 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 837156    

Description Paulo Andrade 2012-11-23 18:48:08 EST
This should be a merge of master branch in f18 branch
of pytz and then submit; but this updates the pytz
version.

This request due to
https://bugzilla.redhat.com/show_bug.cgi?id=837156#c44
Another option I have is to build python3-matplotlib
with it's bundled pytz copy.

I think just adapting the patch from
https://bugzilla.redhat.com/show_bug.cgi?id=851226
should do it, and not need to update pytz version
in f18.
Comment 1 Paulo Andrade 2012-11-24 10:22:59 EST
I was toying a bit with adding python3 support on f18
package but it does not work (also by mistake typed
"fedpkg build" instead of "fedpkg local" when doing
a last test in rawhide instead of fedpkg mockbuild
for f18...)

So, it appears the only clean way to add python3
support would be to upgrade to the rawhide version;
I tried start patching, but would require a significant
amount of patches.
Comment 2 Fedora Update System 2012-11-26 11:54:57 EST
pytz-2012d-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pytz-2012d-2.fc18
Comment 3 Fedora Update System 2012-11-26 23:49:23 EST
pytz-2012d-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.