Bug 88034

Summary: Module not loading
Product: [Retired] Red Hat Linux Reporter: Glen Maeding <gmaeding>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-05 16:45:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Glen Maeding 2003-04-04 20:05:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
Sound will not be turned on.  I have a Toshiba 1400-S151. I had Redhat Linux 8.0
and sound worked. Then I upgraded to 9.0 and now the sound module isnt loading
due to this error below when i typed 'dmesg' to see what happened.  Hardware is
detected just fine. I typed /sbin/modprobe trident to load it and this is what i
got from the logs:

"Trident 4DWave/SiS 7018/ALi 5451,Tvia CyberPro 5050 PCI Audio, version
0.14.10h, 18:00:09 Mar 13 2003
PCI: Found IRQ 11 for device 00:06.0
trident: ALi Audio Accelerator found at IO 0xed00, IRQ 11
ALi 5451 did not come out of reset.
trident_ac97_init: error resetting 5451."

I went in to recompile the module with this trident.h and trident.c and other
patches out there, nothing fixed it without having to do a major kernel redo to
one of thos patches, could not do a simple module patch.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /sbin/modprobe trident
2.
3.
    

Actual Results:  It failed to load the module.

Expected Results:  It should have loaded the module and the sound hardware will
spew out music when i play mp3's or whatever.

Additional info:

"/lib/modules/2.4.20-8/kernel/drivers/sound/trident.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-8/kernel/drivers/sound/trident.o: insmod
/lib/modules/2.4.20-8/kernel/drivers/sound/trident.o failed
/lib/modules/2.4.20-8/kernel/drivers/sound/trident.o: insmod trident failed"

Comment 1 Alan Cox 2003-06-05 16:45:26 UTC
Fixed in the current errata