Bug 880911

Summary: [RHEV-RHS] "fsx" process crashed when running "fsx" sanity test on fuse mount
Product: Red Hat Gluster Storage Reporter: spandura
Component: glusterfsAssignee: Raghavendra Bhat <rabhat>
Status: CLOSED DUPLICATE QA Contact: spandura
Severity: unspecified Docs Contact:
Priority: medium    
Version: 2.0CC: grajaiya, racpatel, rhs-bugs, sdharane, shaines, vbellur
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-11 01:45:29 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description spandura 2012-11-28 01:16:30 EST
Description of problem:
=======================
Executing "fsx" fs sanity test on fuse mount for a replicate, distribute-replicate volume fails.

Version-Release number of selected component (if applicable):
============================================================
[11/28/12 - 11:29:10 root@rhs-gp-srv12 system_light]# rpm -qa | grep gluster
glusterfs-fuse-3.3.0rhsvirt1-8.el6.x86_64
glusterfs-3.3.0rhsvirt1-8.el6.x86_64

[11/28/12 - 11:31:32 root@rhs-gp-srv12 system_light]# glusterfs --version
glusterfs 3.3.0rhsvirt1 built on Nov  7 2012 10:11:13


How reproducible:
==================
Often

Steps to Reproduce:
==================
1. Create a replicate volume (1x2) with 2 servers and 1 brick on each server. This is the storage for the VM's.

2. Set the volume option "group" to "virt"

3. Set storage.owner-uid , storage.owner-gid to 36.

4. start the volume. 

5. create a host from RHEVM

6. create a storage domain from RHEVM for the above created volume. 

7. On the host mount point to the volume, run "fsx" sanity test : 
    a. create nfs mount to qa tools ( mount -t nfs 10.70.34.114:/opt /opt )
    b. cd /opt/qa/tools/system_light
    c. ./run.sh -w <mount_point> -l <log_file> -t "fsx" 
  
Actual results:
==================
[11/28/12 - 11:28:59 root@rhs-gp-srv12 system_light]# ./run.sh -w /rhev/data-center/mnt/rhs-client1.lab.eng.blr.redhat.com\:_replicate/ -l /fs_sanity_logs/fs_sanity_replicate_3.3.0rhsvirt1-8.el6.x86_64_`hostname`_`date '+%Y'`"_"`date '+%m'`"_"`date '+%d'`"_"`date '+%H'`"_"`date '+%M'`"_"`date '+%S'`_fsx.log -t "fsx"
/opt/qa/tools/system_light
Tests available:
arequal
bonnie
compile_kernel
dbench
dd
ffsb
fileop
fs_mark
fsx
glusterfs_build
iozone
locks
ltp
multiple_files
openssl
posix_compliance
postmark
read_large
rpc
syscallbench
tiobench
===========================TESTS RUNNING===========================
Changing to the specified mountpoint
/rhev/data-center/mnt/rhs-client1.lab.eng.blr.redhat.com:_replicate/run7466
executing fsx
start:11:29:08
/opt/qa/tools/system_light/scripts/fsx/fsx_run.sh: line 6:  7490 Segmentation fault      (core dumped) fsx -R -W -N $NUM_OPS $FSX_FILE 2>> $LOG_FILE >> $LOG_FILE

real    0m1.371s
user    0m0.002s
sys     0m0.005s
end:11:29:10
fsx failed
0
Total 0 tests were successful
Switching over to the previous working directory
Removing /rhev/data-center/mnt/rhs-client1.lab.eng.blr.redhat.com:_replicate//run7466/
rmdir: failed to remove `/rhev/data-center/mnt/rhs-client1.lab.eng.blr.redhat.com:_replicate//run7466/': Directory not empty
rmdir failed:Directory not empty

output from <log_file>
=====================
[11/28/12 - 11:35:20 root@rhs-gp-srv12 fs_sanity_logs]# cat fs_sanity_replicate_3.3.0rhsvirt1-8.el6.x86_64_rhs-gp-srv12.lab.eng.blr.redhat.com_2012_11_28_11_29_04_fsx.log.failed
mapped writes DISABLED
Size error: expected 0x2250f stat 0x0 seek 0x0
LOG DUMP (1 total operations):
1(1 mod 256): WRITE	0x1f7e6 thru 0x2250e	(0x2d29 bytes) HOLE
Correct content saved for comparison
(maybe hexdump "read" vs "read.fsxgood")


Expected results:
=====================
fsx test should pass. 

Additional info:
==================
Volume Name: replicate
Type: Replicate
Volume ID: d93217ad-aa06-49df-80bf-b0539e5eba72
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: rhs-client1:/disk1
Brick2: rhs-client16:/disk1
Options Reconfigured:
storage.owner-gid: 36
storage.owner-uid: 36
cluster.eager-lock: enable
storage.linux-aio: enable
performance.stat-prefetch: off
performance.io-cache: off
performance.read-ahead: off
performance.quick-read: off


Note: The same test passes when executed on regular file system
===============================================================
[11/28/12 - 11:40:52 root@rhs-gp-srv12 system_light]# rm -rf /fsx_testdir ; mkdir /fsx_testdir ; ./run.sh -w /fsx_testdir/ -l /fs_sanity_logs/fs_sanity_replicate_3.3.0rhsvirt1-8.el6.x86_64_`hostname`_`date '+%Y'`"_"`date '+%m'`"_"`date '+%d'`"_"`date '+%H'`"_"`date '+%M'`"_"`date '+%S'`_fsx.log -t "fsx"
/opt/qa/tools/system_light
Tests available:
arequal
bonnie
compile_kernel
dbench
dd
ffsb
fileop
fs_mark
fsx
glusterfs_build
iozone
locks
ltp
multiple_files
openssl
posix_compliance
postmark
read_large
rpc
syscallbench
tiobench
===========================TESTS RUNNING===========================
Changing to the specified mountpoint
/fsx_testdir/run8392
executing fsx
start:11:41:52

real    0m0.014s
user    0m0.008s
sys     0m0.004s
end:11:41:52
Removed fsx file
1
Total 1 tests were successful
Switching over to the previous working directory
Removing /fsx_testdir//run8392/

output from <log_file>
========================
[11/28/12 - 11:35:28 root@rhs-gp-srv12 fs_sanity_logs]# cat fs_sanity_replicate_3.3.0rhsvirt1-8.el6.x86_64_rhs-gp-srv12.lab.eng.blr.redhat.com_2012_11_28_11_28_47_fsx.log.passed
mapped writes DISABLED
truncating to largest ever: 0x32740
truncating to largest ever: 0x39212
truncating to largest ever: 0x3bae9
truncating to largest ever: 0x3c1e3
truncating to largest ever: 0x3d1cd
All operations completed A-OK!
Comment 3 Rachana Patel 2012-12-03 01:23:05 EST
It is also failing for DHT volume - FUSE mount
Comment 4 Vijay Bellur 2012-12-11 01:45:29 EST

*** This bug has been marked as a duplicate of bug 856467 ***