Bug 881040

Summary: [RFE] engine: Cannot run VM as stateless per specific disks
Product: Red Hat Enterprise Virtualization Manager Reporter: Tal Nisan <tnisan>
Component: RFEsAssignee: Michal Skrivanek <michal.skrivanek>
Status: CLOSED WONTFIX QA Contact: yeylon <yeylon>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.2.0CC: abaron, acathrow, hateya, iheim, jkt, lpeer, michal.skrivanek, Rhev-m-bugs, scohen, srevivo, wwz, yeylon
Target Milestone: ---Keywords: FutureFeature
Target Release: 3.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: virt
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-07 11:33:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tal Nisan 2012-11-28 13:38:40 UTC
Description of problem:
When running VM as stateless it is running as stateless for all disks (Which are snappable), there is no option to run a VM as stateless per disk

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. In webadmin VM list select a VM and click on "Run once"
2. Click on the Boot options menu and check the "Run Stateless" checkbox
3. Click OK
  
Actual results:
VM is run as stateless for every one of it's snappable disks

Expected results:
There should be a selection of which disk should be Stateless in the current run

Additional info:

Comment 1 Itamar Heim 2012-11-29 11:27:49 UTC
need to decide if this is only at run-once, or relevant for any run vm.
also need to decide if to change disk creation time to create the stateless directly on top of the template (image), or like today, over a disk created on top of the image.
this is probably regardless of run once behavior

Comment 2 Ayal Baron 2012-11-29 12:58:03 UTC
It cab be even more complicated then that.  Do we allow setting stateless disk at template level?

First wrt run once, I don't understand the use case for stateless disks (i.e. partially stateless vm) in run once.
The point for run once with stateless as I see it is not to change the base VM state.  If some of the disks are stateful then that beats the purpose.

So perhaps we'd *allow* it in run once (because users always think of uses we don't) I wouldn't target that as the main use case.

Assuming we go with the above then to address the second question of disk created on top of the image or directly over the template, I would go with the former since it's simpler wrt existing flows (e.g. no need to think about new validations when removing the backing file while it has VMs that reference it without having an actual image over it).

Comment 3 Itamar Heim 2012-12-03 23:04:16 UTC
i agree, for images, creating the COW on VM launch would be simpler.

but the fact they are always stateless in ec2 doesn't mean we must copy that part.
i can attest it is quite annoying to use, and i'd rather be able to specify my image disks are stateful, rather than stateless.

Comment 6 Michal Skrivanek 2014-01-07 11:33:36 UTC
UI-wise we may have something better with instance types, till then it would be  confusing to manage, I'd stick with all or nothing for now