Bug 881099

Summary: RFE: virt-manager cloning dialog enhancements - hostname missing
Product: [Community] Virtualization Tools Reporter: Frantisek Reznicek <freznice>
Component: virt-managerAssignee: Cole Robinson <crobinso>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: acathrow, berrange, crobinso, esammons, hbrock, jforbes, jsynacek, virt-maint
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-01 18:59:42 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Frantisek Reznicek 2012-11-28 11:23:22 EST
Description of problem:

[RFE] virt-manager cloning dialog enhancements - machine ID missing

Scenario:
  virt-manager displaying VMs located on localhost
           and displaying also VMs from remote host H (qemu+ssh)

  When user does machine clone on host H's VM he might get impression that VM will be cloned to localhost i.e. migrated to localhost which is not the case.


I thus propose to tune the cloning UI dialog the way it would be clear that in above situation the cloning will be done on host H.

In other words cloning UI dialog has to state host ID (FQDN).

Proposal:
  Add '[Cloning] hostname: <fqdn>' above Name: ...


Version-Release number of selected component (if applicable):
libvirt-0.9.11.7-1.fc17.x86_64
libvirt-client-0.9.11.7-1.fc17.x86_64
libvirt-daemon-0.9.11.7-1.fc17.x86_64
libvirt-daemon-config-network-0.9.11.7-1.fc17.x86_64
libvirt-daemon-config-nwfilter-0.9.11.7-1.fc17.x86_64
libvirt-python-0.9.11.7-1.fc17.x86_64
python-virtinst-0.600.3-2.fc17.noarch
qemu-kvm-1.0.1-2.fc17.x86_64
redland-virtuoso-1.0.15-1.fc17.x86_64
virt-manager-0.9.4-2.fc17.noarch
virt-manager-common-0.9.4-2.fc17.noarch
virt-viewer-0.5.3-1.fc17.x86_64
virtuoso-opensource-6.1.6-1.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. at least one machine created
2. start 'virt-manager'
3. right-click -> Clone...
4. try to find information what is the target machine where the cloned machine will be stored.
  
Actual results:
Cloning UI dialog do not show hostname.

Expected results:
Cloning UI dialog has to show hostname.
Comment 1 Jan Synacek 2012-12-11 08:33:21 EST
The user should also be able to cancel a cloning in progress.
Comment 2 Cole Robinson 2013-04-01 06:00:57 EDT
Since it's an RFE, moving to the upstream tracker.
Comment 3 Cole Robinson 2014-02-01 18:59:42 EST
Fixed upstream now