Bug 881581

Summary: SELinux is preventing /usr/lib/systemd/systemd-timedated from 'rename' accesses on the file .adjtimeZHQmx1.
Product: [Fedora] Fedora Reporter: Steve Tyler <stephent98>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:1b66e31064a889a1e39bc9efa64b16c96310efb2786906fde1f6ba36d3b61b0b
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-29 12:41:15 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: type
none
File: hashmarkername none

Description Steve Tyler 2012-11-29 01:55:15 EST
Additional info:
libreport version: 2.0.17
kernel:         3.6.6-3.fc18.i686

description:
:SELinux is preventing /usr/lib/systemd/systemd-timedated from 'rename' accesses on the file .adjtimeZHQmx1.
:
:*****  Plugin catchall_labels (83.8 confidence) suggests  ********************
:
:If you want to allow systemd-timedated to have rename access on the .adjtimeZHQmx1 file
:Then you need to change the label on .adjtimeZHQmx1
:Do
:# semanage fcontext -a -t FILE_TYPE '.adjtimeZHQmx1'
:where FILE_TYPE is one of the following: locale_t, config_usr_t, systemd_passwd_var_run_t. 
:Then execute: 
:restorecon -v '.adjtimeZHQmx1'
:
:
:*****  Plugin catchall (17.1 confidence) suggests  ***************************
:
:If you believe that systemd-timedated should be allowed rename access on the .adjtimeZHQmx1 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-timedat /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:gnomeclock_t:s0
:Target Context                system_u:object_r:etc_t:s0
:Target Objects                .adjtimeZHQmx1 [ file ]
:Source                        systemd-timedat
:Source Path                   /usr/lib/systemd/systemd-timedated
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           systemd-195-8.fc18.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-50.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.6-3.fc18.i686 #1 SMP Mon Nov 5
:                              16:47:11 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    2012-11-28 22:53:04 PST
:Last Seen                     2012-11-28 22:53:04 PST
:Local ID                      fed9c06a-fa5c-43ff-a410-4c09867be5fd
:
:Raw Audit Messages
:type=AVC msg=audit(1354171984.566:333): avc:  denied  { rename } for  pid=2055 comm="systemd-timedat" name=".adjtimeZHQmx1" dev="sda8" ino=26937 scontext=system_u:system_r:gnomeclock_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file
:
:
:type=AVC msg=audit(1354171984.566:333): avc:  denied  { unlink } for  pid=2055 comm="systemd-timedat" name="adjtime" dev="sda8" ino=355 scontext=system_u:system_r:gnomeclock_t:s0 tcontext=system_u:object_r:adjtime_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1354171984.566:333): arch=i386 syscall=rename success=yes exit=0 a0=b862fa68 a1=b77606ca a2=b7766da8 a3=b77606ca items=0 ppid=1 pid=2055 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-timedat exe=/usr/lib/systemd/systemd-timedated subj=system_u:system_r:gnomeclock_t:s0 key=(null)
:
:Hash: systemd-timedat,gnomeclock_t,etc_t,file,rename
:
:audit2allow
:
:#============= gnomeclock_t ==============
:allow gnomeclock_t adjtime_t:file unlink;
:allow gnomeclock_t etc_t:file rename;
:
:audit2allow -R
:
:#============= gnomeclock_t ==============
:allow gnomeclock_t adjtime_t:file unlink;
:allow gnomeclock_t etc_t:file rename;
:
Comment 1 Steve Tyler 2012-11-29 01:55:18 EST
Created attachment 654013 [details]
File: type
Comment 2 Steve Tyler 2012-11-29 01:55:19 EST
Created attachment 654014 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-11-29 12:41:15 EST

*** This bug has been marked as a duplicate of bug 881577 ***