Bug 881623

Summary: [ALL_LANG][SAM Web GUI] - Visually Disable Button acting as if it is enabled and showing messages
Product: Subscription Asset Manager Reporter: Satyabrata Maitra <smaitra>
Component: katelloAssignee: Bryan Kearney <bkearney>
Status: CLOSED ERRATA QA Contact: SAM QE List <sam-qe-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.3CC: bkearney, eng-i18n-bugs, lijli, qe-i18n-bugs, smaitra, sthirugn, tkolhar, tomckay
Target Milestone: rcKeywords: i18n, Translation, Triaged
Target Release: 1.3   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 995946 (view as bug list) Environment:
Last Closed: 2013-10-01 06:53:54 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 833466, 995946    
Attachments:
Description Flags
Disabled button acts as an enabled one. none

Description Satyabrata Maitra 2012-11-29 03:32:10 EST
Created attachment 654052 [details]
Disabled button acts as an enabled one.

Description of problem:
For all the languages, in the Admin page (Home page --> Admin --> Click on any existing user on the left pane --> Details), the button for "Clear Disabled Helptips" functionality behaving a little odd way when it is disabled.
The first time, when it remains Enabled and user can click to clear. Then, the button text changes from "Clear" to "Cleared" and becomes visually disabled. Ideally it can not be clicked or should not show the same message upon click as like when it was enabled.
But, even after then button is Disabled, first of all, user can click and can also realize that the click action occurred because the message is showing "Disabled Help tips have been re-enabled" following the click action.

Version-Release number of selected component (if applicable):
katello-headpin-all-1.2.5-1h.el6_3
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
Always

Steps to Reproduce:
1. Login in SAM GUI with Admin rights
2. Click on Admin (right-above the home page)
3. Click on any existing user.
4. Click on Enabled "Clear" button on the User "Detail" page.
5. Observe the message showing above and disappears.
6. Now observe the same clear button showing the text "Cleared" instead of 
   "Clear". 
7. Now Again Click on the "Cleared" button.
8. Observe the same message showing again upon every click and disappears.

Actual results:
The button property set wrongly, allowing user to click on it even when it is disable and showing message upon that click action.

Expected results:
No Disabled button should either allow user to click on it/restrict the mouse click/selection option OR it should allow to show any message further upon click.

Additional info: Screen Shot attached.
Comment 2 Payal Godhani 2013-07-29 14:51:36 EDT
https://github.com/Katello/katello/pull/2692
Comment 3 Bryan Kearney 2013-08-02 14:52:41 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 5 Tazim Kolhar 2013-08-12 11:57:20 EDT
VERIFIED:

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch


Disables Buttons do not show the display message and user cannot
click the disabled button
Comment 7 errata-xmlrpc 2013-10-01 06:53:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html