Bug 88252

Summary: doesn't start with GUI
Product: [Retired] Red Hat Linux Reporter: Volker Meyer <v.meyer>
Component: redhat-config-dateAssignee: Brent Fox <bfox>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-20 16:09:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Volker Meyer 2003-04-08 07:04:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0 (BDP)

Description of problem:
Starting redhat-config-date from a running X-Server produces the following error:
---
(redhat-config-date.py:4429): Gdk-WARNING **: DESKTOP_STARTUP_ID contains
invalid UTF-8
redhat-config-date requires a currently running X server.
---

Version-Release number of selected component (if applicable):
redhat-config-date-1.5.9-8

How reproducible:
Always

Steps to Reproduce:
1. run redhat-config-date
2.
3.
    

Actual Results:  see error

Expected Results:  what?

Additional info:

Above warning comes with EVERY redhat-config-... tool.
Some start, some don't.
redhat-config-date doesn't.
redhat-config-users does.

Comment 1 Brent Fox 2003-04-14 19:36:52 UTC
What are the contents of the /etc/sysconfig/i18n file?  I am not seeing this
behavior on my test machines.

Comment 2 Volker Meyer 2003-04-15 05:06:36 UTC
There's no such file on my system.
I checked all 3 CDs from RH9. There's no package, providing this file.
What should be in it?


Comment 3 Brent Fox 2003-05-20 16:09:26 UTC
The /etc/sysconfig/i18n file is created by the installer during installation, so
it's not in any package.  If this file is not present, the system has no way of
knowing what language the system should use. 

Since you are emailing me from a .de domain, I'm assuming that you want your
system to use German as the default language.  If so, your /etc/sysconfig/i18n
file should look like:

LANG="de_DE.UTF-8"
SYSFONT="latarcyrheb-sun16"
SYSFONTACM="utf8"

Creating the file with those contents should allow redhat-config-date to run. 
However, a bigger question is how that file got deleted.  I can't really help
answer that question.  

Please reopen this bug report if the problem doesn't go away after creating the
file.