Bug 882977

Summary: When Installing openstack-swift, The packages python-keystone-auth-token should be installed by dependency.
Product: Red Hat OpenStack Reporter: Nir Magnezi <nmagnezi>
Component: openstack-swiftAssignee: Martin Magr <mmagr>
Status: CLOSED ERRATA QA Contact: Omri Hochman <ohochman>
Severity: unspecified Docs Contact:
Priority: high    
Version: 2.0 (Folsom)CC: apevec, jhenner, zaitcev
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-swift-1.7.4-3.el6ost Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-14 13:23:03 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
swift startup log none

Description Nir Magnezi 2012-12-03 09:30:40 EST
Description of problem:
=======================

When Installing openstack-swift, The packages python-keystone-auth-token should be installed by dependency.
I installed openstack in a distributed way, Meaning a single service per Host/VM.
I'd expect that all the packages needed for me to configure and run that service, to be installed by dependency.

Based on Chapter 9. Swift (Object Storage):
https://access.redhat.com/knowledge/docs/en-US/Red_Hat_OpenStack_Preview/2/html-single/Getting_Started_Guide/index.html
I installed swift on a single host, Started the openstack-swift-proxy and noticed errors at /var/log/swift-startup.log


Version-Release number of selected component (if applicable):
=============================================================
Folsom.

How reproducible:
=================
Always.

Steps to Reproduce:
===================
1. Chapter 9. Swift (Object Storage)  on: https://access.redhat.com/knowledge/docs/en-US/Red_Hat_OpenStack_Preview/2/html-single/Getting_Started_Guide/index.html
2. While starting openstack-swift-proxy, tail -f /var/log/swift-startup.log (output attached to this bug)
 
Actual results:
===============
1. The package python-keystone-auth-token not installed.
2. /var/log/swift-startup.log:

ImportError: No module named keystone.middleware.auth_token

*Log attached to this bug

Expected results:
=================
1. The package python-keystone-auth-token should be installed.
2. No Errors in swift-startup.log.
Comment 2 Nir Magnezi 2012-12-03 09:41:17 EST
Created attachment 656692 [details]
swift startup log
Comment 3 Alan Pevec 2012-12-13 14:29:10 EST
*** Bug 827580 has been marked as a duplicate of this bug. ***
Comment 4 Pete Zaitcev 2012-12-21 14:50:53 EST
What if I am installing a SAIO, for example?
Comment 5 Pete Zaitcev 2012-12-21 14:58:39 EST
To elucidate on the assumptions I'm making above: the downside of adding
the dependencies that _might_ be used, even in a reasonable common case
like the Keystone client, is that we cannot foresee what else the
ostensibly harmless dependency is going to pull. I recall hearing
complaints about this specific case: pulling almost whole of Keystone
onto Swift nodes of operators using swauth.
Comment 6 Alan Pevec 2013-01-11 13:15:07 EST
Done by Martin in openstack-swift-1.7.4-3.el6ost
Comment 8 Nir Magnezi 2013-01-17 10:24:22 EST
Verified. with openstack-swift Version: 1.7.4-4.el6ost


[root@nmagnezi_swift_proxy ~]# yum install openstack-swift
Loaded plugins: product-id, rhnplugin, security, subscription-manager
...

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                                    Arch                                Version                                                Repository                                             Size
===================================================================================================================================================================================================================
Installing:
 openstack-swift                                            noarch                              1.7.4-4.el6ost                                         OpenStack-Folsom-Puddle                               275 k
Installing for dependencies:
 MySQL-python                                               x86_64                              1.2.3-0.3.c1.1.el6                                     rhel-x86_64-server-6.3.z                               86 k
 mysql-libs                                                 x86_64                              5.1.66-2.el6_3                                         rhel-x86_64-server-6.3.z                              1.2 M
 openstack-swift-plugin-swift3                              noarch                              1.0.0-0.20120711git.el6                                OpenStack-Folsom-Puddle                                20 k
 python-keystone                                            noarch                              2012.2.1-1.el6ost                                      OpenStack-Folsom-Puddle                               259 k
 python-swiftclient                                         noarch                              1.2.0-2.el6                                            OpenStack-Folsom-Puddle                                46 k

Transaction Summary
===================================================================================================================================================================================================================
Install       6 Package(s)

Total download size: 1.9 M
Installed size: 2.3 M
Is this ok [y/N]: N
Exiting on user Command



The package python-keystone-auth-token installed as python-keystone
Comment 9 Pete Zaitcev 2013-01-19 00:38:01 EST
Actually, it's more like this:

================================================================================
 Package                 Arch      Version               Repository        Size
================================================================================
Installing:
 python-keystone         noarch    2012.2.1-1.el6        epel             260 k
Installing for dependencies:
 MySQL-python            x86_64    1.2.3-0.3.c1.1.el6    rhel-internal     86 k
 PyPAM                   x86_64    0.5.0-12.el6          rhel-internal     23 k
 python-decorator        noarch    3.0.1-3.1.el6         rhel-internal     14 k
 python-iso8601          noarch    0.1.4-2.el6           epel              12 k
 python-memcached        noarch    1.43-6.el6            rhel-internal     32 k
 python-migrate          noarch    0.6-6.el6             epel             208 k
 python-passlib          noarch    1.5.3-1.el6           epel             290 k
 python-routes1.12       noarch    1.12.3-4.el6          epel             691 k
 python-sqlalchemy       noarch    0.5.5-3.el6_2         rhel-internal    1.3 M
 python-sqlalchemy0.7    x86_64    0.7.8-1.el6           epel             2.1 M

Transaction Summary
================================================================================
Install      11 Package(s)

Total download size: 5.0 M
Installed size: 25 M
Is this ok [y/N]: 

And none of that junk is actually needed to run Swift (the box where it's
demonstrated ran Swift just fine without). It's ridiculous.
Comment 11 errata-xmlrpc 2013-02-14 13:23:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0260.html