Bug 883134

Summary: [custom part usability] 'Customize...' label in custom partitioning is too vague
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: anacondaAssignee: Chris Lumens <clumens>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 18CC: duffy, g.kaviyarasu, jonathan, mbanas, sbueno, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Fixed In Version: anaconda-19.3-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-10 23:44:25 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Adam Williamson 2012-12-03 16:02:07 EST
One of the usability issues we've noticed in custom partitioning in Beta is that people are missing all the options behind the 'Customize...' expander in the right-hand pane. Mo doesn't want to expand it by default, but we agreed we could make the label clearer and more explicit: 'Customize...' really gives you absolutely no idea what's behind it.

I don't have a polished suggestion off the top of my head, but I was thinking something along the lines of "Device type, partition type, size, encryption..." - a kind of laundry list of the most popular things behind the expander. We have lots of horizontal space there for a long label.
Comment 1 Martin Banas 2012-12-07 03:20:30 EST
Can we get some statement why it should not be expanded by default? I mean, get rid of + customize at all?..
Comment 2 Máirín Duffy 2012-12-07 10:38:33 EST
Hi Martin - sure. So the idea that kind of goes across the whole UI is like skinning an onion - if you just keep clicking forward, you skip a lot of stuff and it's pretty easy but you don't get to customize so much. If you explicitly decide to peel a layer back, you get to access more options but the level at which you need to be to understand them increases a little bit. 

For the custom partitioning screen, I wanted to promote the very most basic items you could change about a given partition to the very top - the items that pretty much everyone going through custom partitioning might want to modify. The items that depend on a higher level of knowledge about a specific technology (whether it be LVM / BTR / RAID / etc.) we put under the > customize disclosure triangle because not everyone will want to tweak those the way they'd want to tweak the things above it. Showing that kind of very-technology-specific information to everyone, while it makes it convenient for the experts, it also makes it a bit bewildering for the folks who just want to change a mount point or the size of a partition. 

Where there is tension between making things more convenient for a technology expert user vs. making them easier for a less sophisticated user, I always opt to make it easier for the less sophisticated user. Typically, the same exact task is a lot more effort (time, confusion, etc.) for the less sophisticated user so it's more fair that way. 

Also, it's seriously just one additional click. Would it make it easier if we remembered the state of the expander so if you open up customize on one partition, go to another, and come back, it stays open?
Comment 3 Adam Williamson 2012-12-10 19:43:31 EST
mairin: that might be a neat improvement. The problem with having it closed isn't that opening it is particularly strenuous or annoying - of course not, it's just one click - it's that people are missing it, or not guessing what's behind it. I've seen multiple complaints along the lines of 'I can't figure out how to do X!' when X is 'something behind this expander'.
Comment 4 Martin Banas 2012-12-11 03:38:08 EST
this would be nice, to remember the state of the expander.

Comment 5 Chris Lumens 2013-01-29 11:03:48 EST
I think Mo has done a very good job of explaining the reasoning behind the expander.  I've committed a patch for remembering it state, though, and will be posting it shortly.
Comment 6 Adam Williamson 2013-01-29 12:02:08 EST
Well, this bug is not about removing it or remembering its state, but changing the label...
Comment 7 Chris Lumens 2013-01-29 14:37:53 EST
I don't think we necessarily need to change the wording given that it's the only expander on the screen.  However, if we do, then something simple would be best in my mind - not the least of which because it'd be easier to translate.  Something like "Advanced Settings", perhaps?
Comment 8 Adam Williamson 2013-01-29 16:02:11 EST
"I don't think we necessarily need to change the wording given that it's the only expander on the screen."

the bug was based on practical feedback: I saw multiple people in the forums saying they couldn't find where to configure the stuff that's behind the expander. You'd *think* people would just click around and find it, but apparently not. And I don't see any harm in labelling a thing with what it really is, rather than a vague verb.
Comment 9 Adam Williamson 2013-01-30 17:59:21 EST
In discussion in #anaconda today, we agreed on the label "Device and file system options..." to replace "Customize..."

Can someone make it so? Thanks!
Comment 10 Chris Lumens 2013-01-31 10:03:02 EST
Yes, done.
Comment 11 Adam Williamson 2013-05-10 23:44:25 EDT
Well hey, somehow I didn't notice, but at some point between 18 final and 19 Beta TC4, we have lost the expander entirely. I dunno if that's an oversight or if we just decided to get rid of it (which I would endorse!), but this is clearly resolved.
Comment 12 Máirín Duffy 2013-05-13 20:06:29 EDT
we decided to nix the expander completely based on the usability test results!
Comment 13 Adam Williamson 2013-05-13 21:02:21 EDT
Welcome to the forces of truth, light and goodness ;)