Bug 88346

Summary: '/bin/ls -l' is not properly aligned for the zh_CN locale
Product: [Retired] Red Hat Linux Reporter: Need Real Name <zlb>
Component: coreutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: mitr
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 5.0-5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-28 09:27:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Sample output
none
Expected output none

Description Need Real Name 2003-04-09 06:56:09 UTC
Description of problem:

An easy bug:

The filename field of the command 'ls -l' is not properly aligned
under the locale zh_CN.GB18030. Please see attached file ls-rh9.jpg.
For comparison, I also attached a sample output using the 'ls'
program from the fileutils package of RedHat-8.0 (ls-rh8.jpg).

Version-Release number of selected component (if applicable)

coreutils-4.5.3-19

How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:

See ls-rh9.jpg

Expected results:

See ls-rh8.jpg

Additional info:

Comment 1 Need Real Name 2003-04-09 06:57:32 UTC
Created attachment 91030 [details]
Sample output

Comment 2 Need Real Name 2003-04-09 06:58:26 UTC
Created attachment 91031 [details]
Expected output