This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 883476

Summary: X Hangs on boot with 3.6.8-2.fc17.x86_64 kernel
Product: [Fedora] Fedora Reporter: Matthew Labarge <mlabarge>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: airlied, ajax, bskeggs, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-09 09:36:48 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Matthew Labarge 2012-12-04 12:01:52 EST
Description of problem:
When booting with 3.6.8-2.fc17.x86_64 kernel, When display Manager starts. Machine will just hang. Off a fresh install CD, with kernel 3.3.4-5.fc17.x86_64 Gnome 3 loads fine. As soon as you perform an update however, machine locks up at boot. Have added nomodeset and nouveau.noaccel=1 to kernel params with no success. Also tried installing akmod-nvidia and blacklisting nouveau. Also, no go. 


Version-Release number of selected component (if applicable):

xorg-x11-drv-nouveau-0.0.16-37.20120306gitf5d1cd2.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. Load F17 off CD. 
2. Perform Yum update
3. Reboot
  
Actual results:
Machine Locks up. Unable to switch tty. Have to perform hard reset to laptop. 

Expected results:
Gnome 3 loads. 

Additional info:

Hardware:
Dell Lattitude E6520 with nVidia Corporation GF108 [Quadro NVS 4200M]
Comment 1 Matthew Labarge 2012-12-04 15:43:46 EST
Performed a yum update -x kernel. Still no issues.
Comment 2 Ben Skeggs 2012-12-11 01:46:14 EST
As per "Have added nomodeset" (which completely disables nouveau) and "Also tried installing akmod-nvidia and blacklisting nouveau" - not a nouveau bug.  Reassigning.
Comment 3 Matthew Labarge 2012-12-12 12:36:31 EST
Upon further investigation it appears to be related to the wireless hardware kill switch on the laptop. When the switch is enabled(Bluetooth and wifi hardware disabled via hardware switch) the graphical environment never loads. However, when the switch is disabled(Bluetooth and wifi hardware enabled via hardware switch) everything runs find. 

Any particular information or commands I can run for further information?
Comment 4 Josh Boyer 2013-01-03 14:10:46 EST
If you remove 'quiet rhgb' from the kernel command line, do you get oops output on the screen during boot with the hardware kill switch enabled?
Comment 5 Josh Boyer 2013-01-09 09:36:48 EST
After reviewing other bugs, this is likely a duplicate of 854069

*** This bug has been marked as a duplicate of bug 854069 ***