Bug 884601 (CVE-2013-0220)

Summary: CVE-2013-0220 sssd: Out-of-bounds read flaws in autofs and ssh services responders
Product: [Other] Security Response Reporter: Jan Lieskovsky <jlieskov>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: fweimer, jcholast, security-response-team, ssorce
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=low,public=20130123,reported=20121205,source=redhat,cvss2=5.0/AV:N/AC:L/Au:N/C:N/I:N/A:P,rhel-5/sssd=notaffected,rhel-6/sssd=affected,fedora-all/sssd=affected,epel-5/sssd=notaffected,cwe=CWE-125[auto]
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-21 23:50:51 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 883878, 903078, 903145    
Bug Blocks: 855229, 884256    
Attachments:
Description Flags
Proposed patch by Jan Cholasta none

Description Jan Lieskovsky 2012-12-06 06:24:51 EST
Multiple out-of-buffer bounds read flaws were found in the way autofs and ssh service responders of sssd, a System Security Services Daemon, performed parsing of SSSD packet values. An attacker could provide a specially-crafted packet that, when processed by the autofs or ssh service responders of sssd would lead to sssd server crash (temporary denial of service).

This issue was found by Florian Weimer of Red Hat Product Security Team.
Comment 1 Jan Lieskovsky 2012-12-06 06:29:29 EST
This issue did NOT affect the version of the sssd package, as shipped with Red Hat Enterprise Linux 5 as it did not include support for autofs and ssh responders yet.

--

This issue affects the version of the sssd package, as shipped with Red Hat Enterprise Linux 6.

--

This issue affects versions of the sssd package, as shipped with Fedora release of 16 and 17.

--

This issue did NOT affect the version of the sssd package, as shipped with Fedora EPEL 5 as it did not include support for autofs and ssh responders yet.
Comment 2 Jan Lieskovsky 2012-12-06 06:32:00 EST
Created attachment 658700 [details]
Proposed patch by Jan Cholasta
Comment 3 Huzaifa S. Sidhpurwala 2013-01-23 00:23:10 EST
This issue has been assigned CVE-2013-0220
Comment 5 Huzaifa S. Sidhpurwala 2013-01-23 05:13:24 EST
Created sssd tracking bugs for this issue

Affects: fedora-all [bug 903145]
Comment 6 Fedora Update System 2013-02-09 06:24:08 EST
sssd-1.9.4-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Murray McAllister 2013-02-10 01:53:28 EST
Acknowledgements:

These issues were discovered by Florian Weimer of the Red Hat Product Security Team.
Comment 8 Fedora Update System 2013-02-11 23:57:45 EST
sssd-1.8.6-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 errata-xmlrpc 2013-02-21 04:42:13 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2013:0508 https://rhn.redhat.com/errata/RHSA-2013-0508.html