Bug 885313

Summary: hexdump segfault
Product: Red Hat Enterprise Linux 6 Reporter: GV <rhel>
Component: util-linux-ngAssignee: Karel Zak <kzak>
Status: CLOSED ERRATA QA Contact: qe-baseos-daemons
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.3CC: azelinka, kvolny, ohudlick, psklenar
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: util-linux-ng-2.17.2-12.13.el6 Doc Type: Bug Fix
Doc Text:
Cause: The command hexdump segfaults when iterating over an empty format string. Consequence: Fix: Result:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-21 20:44:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description GV 2012-12-08 15:10:04 UTC
Description of problem:

$ printf \\1 | hexdump -n1 -ve '8/2 "" "%04x" ""'
Segmentation fault

Comment 2 Karel Zak 2013-01-10 10:43:23 UTC
Fixed by upstream commit f1107b4a873f6c2dcfcaf0135efc72badb46bc77.

Comment 6 errata-xmlrpc 2013-11-21 20:44:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1648.html