Bug 885419

Summary: [abrt]: WARNING: at drivers/usb/core/urb.c:311 usb_submit_urb+0x3bc/0x3d0() [uvcvideo]
Product: [Fedora] Fedora Reporter: Philipp Dreimann <philipp>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: abyss.7, amar9986, ambijat, amitabh_rs, artem.goncharov, bugzilla, christianvanbrauner, constantine.karnacevych, dandreadante, deadgnom32, dregis, erkanyalcin, fito.nefty, gabriel.amador.garcia, gansalmon, gerhard.dekker, griboedova, horny.sama, ihatewindoze, informatic.0912, itamar, jmj.buckley, jonathan, kernel-maint, kmrvimal, konstantinjch, kristinethster, laurent.pinchart, lists.kho, luigi.3010, madhavvamsi716, madhu.chinakonda, marcelotheodoro, mikbear, myxa205, nihar_smily17, pat, paulo.ferreira25, philipp, prabhjotsinghsaini88, prideandsuccess, ramez.hanna, rene.schaffrath+rhbz, salman.zarrini, thiago.mosqueiro, w
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:c13e4276114c599b880deab4c9c2c70f3a73415c
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-27 11:09:18 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Philipp Dreimann 2012-12-09 05:02:27 EST
Additional info:
WARNING: at drivers/usb/core/urb.c:311 usb_submit_urb+0x3bc/0x3d0()
Hardware name: 4290W4H
URB ffff88020bf173c0 submitted while active
Modules linked in: cpufreq_stats tcp_lp fuse ebtable_nat ebtables nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 ip6t_REJECT cxgb3i cxgb3 mdio nf_conntrack_ipv6 libcxgbi nf_defrag_ipv6 ib_iser rdma_cm ib_addr ip6table_filter iw_cm ip6_tables ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi iptable_nat nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack rfcomm bnep snd_hda_codec_hdmi snd_hda_codec_conexant vfat btusb fat bluetooth arc4 iwldvm mac80211 iTCO_wdt iTCO_vendor_support coretemp joydev uvcvideo microcode videobuf2_vmalloc videobuf2_memops videobuf2_core snd_hda_intel i2c_i801 videodev snd_hda_codec media snd_hwdep snd_seq lpc_ich snd_seq_device mfd_core binfmt_misc snd_pcm iwlwifi cfg80211 snd_page_alloc mei snd_timer thinkpad_acpi snd soundcore rfkill tpm_tis vhost_net tpm tun tpm_bios macvtap macvlan kvm_intel kvm uinput btrfs libcrc32c zlib_deflate i915 crc32c_intel i2c_algo_bit drm_kms_helper ghash_clmulni_intel drm sdhci_pci e1000e sdhci mmc_core i2c_core wmi video dm_multipath sunrpc
Pid: 29473, comm: skype Not tainted 3.6.9-4.fc18.x86_64 #1
Call Trace:
 [<ffffffff8105c8df>] warn_slowpath_common+0x7f/0xc0
 [<ffffffff8105c9d6>] warn_slowpath_fmt+0x46/0x50
 [<ffffffff8117b63f>] ? kmem_cache_alloc_trace+0x12f/0x160
 [<ffffffff8143fd9c>] usb_submit_urb+0x3bc/0x3d0
 [<ffffffffa04ccdc1>] uvc_status_start+0x21/0x30 [uvcvideo]
 [<ffffffffa04c5f92>] uvc_v4l2_open+0xb2/0x160 [uvcvideo]
 [<ffffffffa046775d>] v4l2_open+0x12d/0x1a0 [videodev]
 [<ffffffff81194d6b>] chrdev_open+0x9b/0x180
 [<ffffffff8118ec53>] do_dentry_open+0x203/0x290
 [<ffffffff81194cd0>] ? cdev_put+0x30/0x30
 [<ffffffff8118ed15>] finish_open+0x35/0x50
 [<ffffffff8119face>] do_last+0x6de/0xdf0
 [<ffffffff8119c7d8>] ? inode_permission+0x18/0x50
 [<ffffffff8119c887>] ? link_path_walk+0x77/0x880
 [<ffffffff811553db>] ? handle_pte_fault+0x49b/0xb10
 [<ffffffff811a029a>] path_openat+0xba/0x4d0
 [<ffffffff811a0911>] do_filp_open+0x41/0xa0
 [<ffffffff811ac9cd>] ? alloc_fd+0x4d/0x120
 [<ffffffff8118fc76>] do_sys_open+0xf6/0x1e0
 [<ffffffff810d8d6c>] ? __audit_syscall_entry+0xcc/0x300
 [<ffffffff811debfb>] compat_sys_open+0x1b/0x20
 [<ffffffff8162cda6>] sysenter_dispatch+0x7/0x21

Potential duplicate: bug 879462
Comment 1 Patrick Dubois 2013-01-20 14:50:57 EST
I had a Logitech z-10 speaker set plugged in at the time.
Comment 2 amar 2013-02-06 20:58:14 EST
when i connect huawei modem to network, when net gets connected , 30 - 60 seconds after that

Package: kernel
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 3 Dave Jones 2013-02-07 11:29:42 EST
*** Bug 890696 has been marked as a duplicate of this bug. ***
Comment 4 Constantine Karnacevych 2013-02-08 21:47:42 EST
seen after KDE started

Package: kernel
OS Release: Fedora release 18 (Spherical Cow)
Comment 5 v.plessky 2013-03-11 00:10:52 EDT
Experienced this problem after logon

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 6 Gabriel Amador 2013-03-18 17:30:22 EDT
I was starting google chrome, evolution and filezilla. 

Package: kernel
OS Release: Fedora release 18 (Spherical Cow)
Comment 7 Gerhard Dekker 2013-04-01 14:19:48 EDT
Description of problem:
The computer was suspended ... i think the problem occured when i woke it up

Version-Release number of selected component:
kernel

Additional info:
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.0-0.rc4.git0.2.fc20.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 rd.luks=0 vconsole.keymap=us rd.lvm.lv=fedora/root rhgb quiet LANG=en_GB.UTF-8
kernel:         3.9.0-0.rc4.git0.2.fc20.x86_64
type:           Kerneloops
ureports_counter: 1

Truncated backtrace:
WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3be/0x3d0()
Hardware name: HP Pavilion g6 Notebook PC      
URB ffff8801434336c0 submitted while active
Modules linked in: ebtable_nat fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 bnep iptable_nat nf_nat_ipv4 nf_nat bluetooth iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_hda_codec_hdmi snd_hda_codec_idt rtsx_pci_ms snd_usb_audio snd_hda_intel arc4 rt2800pci rt2800lib rt2x00pci snd_usbmidi_lib snd_hda_codec iTCO_wdt uvcvideo videobuf2_vmalloc rt2x00lib memstick videobuf2_memops videobuf2_core videodev iTCO_vendor_support media snd_rawmidi rtsx_pci_sdmmc mmc_core rtsx_pci eeprom_93cx6 lpc_ich mac80211 cfg80211 mfd_core crc_ccitt i2c_i801 snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd soundcore vhost_net mei joydev hp_wmi mperf coretemp microcode sparse_keymap rfkill tun macvtap macvlan kvm_intel kvm uinput i915 i2c_algo_bit crc32_pclmul crc32c_intel drm_kms_helper ghash_clmulni_intel drm r8169 mii i2c_core wmi video sunrpc
Pid: 1961, comm: MediaStreamDevi Not tainted 3.9.0-0.rc4.git0.2.fc20.x86_64 #1
Call Trace:
 [<ffffffff8145cb00>] ? usb_submit_urb+0x360/0x3d0
 [<ffffffff8105c9d0>] warn_slowpath_common+0x70/0xa0
 [<ffffffff8105ca4c>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff8164031a>] ? _cond_resched+0x3a/0x50
 [<ffffffff81180f3f>] ? kmem_cache_alloc_trace+0x1cf/0x230
 [<ffffffff8145cb5e>] usb_submit_urb+0x3be/0x3d0
 [<ffffffffa049be71>] uvc_status_start+0x21/0x30 [uvcvideo]
 [<ffffffffa049524b>] uvc_v4l2_open+0x9b/0x140 [uvcvideo]
 [<ffffffffa0436585>] v4l2_open+0xc5/0x120 [videodev]
 [<ffffffff8119d4ac>] chrdev_open+0x9c/0x180
 [<ffffffff811973bb>] do_dentry_open+0x1eb/0x280
 [<ffffffff8119d410>] ? cdev_put+0x30/0x30
 [<ffffffff81197481>] finish_open+0x31/0x40
 [<ffffffff811a6e49>] do_last+0x4d9/0xe40
 [<ffffffff812943c1>] ? selinux_file_alloc_security+0x41/0x70
 [<ffffffff811a7860>] path_openat+0xb0/0x4d0
 [<ffffffff811a82f8>] do_filp_open+0x38/0x80
 [<ffffffff811b46a0>] ? __alloc_fd+0x80/0x120
 [<ffffffff81198739>] do_sys_open+0xe9/0x1c0
 [<ffffffff81198831>] sys_open+0x21/0x30
 [<ffffffff81649fd9>] system_call_fastpath+0x16/0x1b
Comment 8 Josh Boyer 2013-04-01 16:00:18 EDT
Seems we're still hitting some uvcvideo issues here.
Comment 9 Luigi Pardey 2013-04-17 04:20:54 EDT
Same problem, upon turning on the pc.

Hardware: Samsung R580
Version: Fedora 17 x86_64
Kernel: 3.8.4-102.fc17.x86_64


Trace:

WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3b4/0x3d0()
Hardware name: R580                       
URB ffff88012d6aa3c0 submitted while active
Modules linked in: lockd sunrpc rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack binfmt_misc snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq arc4 ath9k ath9k_common ath9k_hw snd_seq_device snd_pcm ath mac80211 cfg80211 btusb coretemp bluetooth kvm_intel snd_page_alloc snd_timer snd soundcore samsung_laptop rfkill uvcvideo iTCO_wdt kvm sky2 videobuf2_vmalloc videobuf2_memops videobuf2_core i2c_i801 iTCO_vendor_support lpc_ich mfd_core videodev media microcode serio_raw uinput crc32c_intel nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core
Pid: 1073, comm: knotify4 Not tainted 3.8.4-102.fc17.x86_64 #1
Call Trace:
[<ffffffff8105e63f>] warn_slowpath_common+0x7f/0xc0
[<ffffffff8105e736>] warn_slowpath_fmt+0x46/0x50
[<ffffffff81184e8f>] ? kmem_cache_alloc_trace+0x1cf/0x220
[<ffffffff81463c14>] usb_submit_urb+0x3b4/0x3d0
[<ffffffffa026d121>] uvc_status_start+0x21/0x30 [uvcvideo]
[<ffffffffa0265fe2>] uvc_v4l2_open+0xb2/0x160 [uvcvideo]
[<ffffffffa019e535>] v4l2_open+0xd5/0x130 [videodev]
[<ffffffff811a192b>] chrdev_open+0x9b/0x180
[<ffffffff8119b573>] do_dentry_open+0x203/0x290
[<ffffffff811a1890>] ? cdev_put+0x30/0x30
[<ffffffff8119b635>] finish_open+0x35/0x50
[<ffffffff811aba4e>] do_last+0x6de/0xe00
[<ffffffff811a8578>] ? inode_permission+0x18/0x50
[<ffffffff811a8627>] ? link_path_walk+0x77/0x870
[<ffffffff8129e70a>] ? selinux_file_alloc_security+0x4a/0x80
[<ffffffff811ac22c>] path_openat+0xbc/0x4d0
[<ffffffff8129dd25>] ? selinux_inode_getattr+0x45/0x50
[<ffffffff811ac901>] do_filp_open+0x41/0xa0
[<ffffffff811b9012>] ? __alloc_fd+0x42/0x110
[<ffffffff8119c944>] do_sys_open+0xf4/0x1e0
[<ffffffff8119ca51>] sys_open+0x21/0x30
[<ffffffff81654f19>] system_call_fastpath+0x16/0x1b
---[ end trace c1ce5e696a5a4c17 ]---




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 v.plessky 2013-04-28 14:04:39 EDT
Loaded KDE, and got this bug report

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 11 Laurent Pinchart 2013-04-29 08:25:52 EDT
I haven't been able to reproduce the bug and I haven't received any similar report from users of different distros. This will require investigation on the Fedora side.

The status URB can be submitted from uvc_status_start() (when the device is opened) and from uvc_status_resume() (when the device is resumed). The bug is triggered by uvc_status_start() being called while the status URB has already been submitted. We first need to find out wjether it was previously submitted by uvc_status_start() or uvc_status_resume(). printks should help, but this might be related to a race condition, so timings are likely sensitive.
Comment 12 Mohammed Arafa 2013-04-30 20:45:13 EDT
i believe this is related to my lenovo t420's built in camera as it sometimes doesnt work and a reboot is required to get it working
Comment 13 Martin Kho 2013-05-17 18:15:56 EDT
Hi,

Since Fedora 18 got kernel 3.9.2-200, this warning pops up (in abrt) everytime (!) I log in. I've found that on my installation (KDE) amarok (v. 2.7.0 and 2.7.1 from koji) triggers it. When one uses amarok it normally starts automatically after log in (its icon sits in the system tray). When amarok is not started everything is fine. So may be this can be a helpful test, although I don't have  any idea what amarok is doing.

Btw. I've also tried this in Kubuntu 13.04 (amarok 2.7.0) with kernel 3.8.0, and got no warning. So it seems - at this moment - a fedora only issue as Laurent suggested.

HTH.

Martin Kho
Comment 14 Martin Kho 2013-05-24 12:59:36 EDT
Hi,

You may call me mad, crazy, insane or at least completely out of mind, but for me updating libdrm from version 2.4.42 (current in F18) to 2.4.45 (from koji) 'solved' this issue. Don't ask why this package did it. I tried to look at the drm git tree [1] but couldn't see something that could be relevant. Also, Amarok can be enabled again at start up.

May be this can help others too.


Martin Kho

[1] http://cgit.freedesktop.org/mesa/drm/
Comment 15 Thiago Mosqueiro 2013-06-06 13:21:25 EDT
Description of problem:
Complete crash after lock screen.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.4
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.4-200.fc18.x86_64 root=/dev/mapper/fedora_dagoba-root ro rd.md=0 rd.dm=0 rd.lvm.lv=fedora_dagoba/swap rd.lvm.lv=fedora_dagoba/root rd.luks=0 vconsole.keymap=us rhgb quiet LANG=en_US.UTF-8
kernel:         3.9.4-200.fc18.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3b4/0x3d0()
Hardware name: System Product Name
URB ffff8802f42b7800 submitted while active
Modules linked in: fuse ebtable_nat bnep bluetooth rfkill nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_hda_codec_via snd_hda_intel snd_hda_codec snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev ppdev acpi_cpufreq snd_timer media mperf coretemp iTCO_wdt usblp iTCO_vendor_support vhost_net parport_pc parport lpc_ich snd soundcore tun macvtap macvlan mei microcode serio_raw i2c_i801 mfd_core asus_atk0110 kvm_intel kvm uinput ata_generic pata_acpi nouveau crc32_pclmul crc32c_intel mxm_wmi wmi video ghash_clmulni_intel i2c_algo_bit r8169 drm_kms_helper mii ttm pata_jmicron drm i2c_core sunrpc
Pid: 9450, comm: skype Not tainted 3.9.4-200.fc18.x86_64 #1
Call Trace:
 [<ffffffff8105f125>] warn_slowpath_common+0x75/0xa0
 [<ffffffff8105f206>] warn_slowpath_fmt+0x46/0x50
 [<ffffffff811873df>] ? kmem_cache_alloc_trace+0x1cf/0x220
 [<ffffffff81476af4>] usb_submit_urb+0x3b4/0x3d0
 [<ffffffffa03a8161>] uvc_status_start+0x21/0x30 [uvcvideo]
 [<ffffffffa03a1022>] uvc_v4l2_open+0xb2/0x160 [uvcvideo]
 [<ffffffffa037e525>] v4l2_open+0xd5/0x130 [videodev]
 [<ffffffff811a473b>] chrdev_open+0x9b/0x180
 [<ffffffff8119e20b>] do_dentry_open+0x20b/0x290
 [<ffffffff811a46a0>] ? cdev_put+0x30/0x30
 [<ffffffff8119e2c5>] finish_open+0x35/0x50
 [<ffffffff811ae8e9>] do_last+0x6f9/0xe50
 [<ffffffff811ab428>] ? inode_permission+0x18/0x50
 [<ffffffff811ab4d8>] ? link_path_walk+0x78/0x880
 [<ffffffff810978af>] ? __dequeue_entity+0x2f/0x50
 [<ffffffff811af0f7>] path_openat+0xb7/0x4b0
 [<ffffffff811af7b1>] do_filp_open+0x41/0xa0
 [<ffffffff811bbdd2>] ? __alloc_fd+0x42/0x110
 [<ffffffff8119f614>] do_sys_open+0xf4/0x1e0
 [<ffffffff811f080b>] compat_sys_open+0x1b/0x20
 [<ffffffff8166b56c>] sysenter_dispatch+0x7/0x21
Comment 16 Justin M. Forbes 2013-10-18 17:18:01 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 17 Justin M. Forbes 2013-11-27 11:09:18 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  

It has been over a month since we asked you to test the 3.11 kernel updates and let us know if your issue has been resolved or is still a problem. When this happened, the bug was set to needinfo.  Because the needinfo is still set, we assume either this is no longer a problem, or you cannot provide additional information to help us resolve the issue.  As a result we are closing with insufficient data. If this is still a problem, we apologize, feel free to reopen the bug and provide more information so that we can work towards a resolution

If you experience different issues, please open a new bug report for those.
Comment 18 Philipp Dreimann 2015-06-08 14:07:16 EDT
I can not reproduce it anymore.