Bug 885821

Summary: ifup-post doesn't contain #!/bin/bash
Product: [Fedora] Fedora Reporter: Radu Rendec <radu.rendec>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 17CC: iarlyy, jonathan, lnykryn, notting, plautrba, rvokal, vpavlin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-26 02:45:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Radu Rendec 2012-12-10 17:36:58 UTC
Description of problem:
/etc/sysconfig/network-scripts/ifup-post doesn't contain #!/bin/bash at the beginning of the file, therefore it cannot be executed as a separate shell (process).

Version-Release number of selected component (if applicable):
initscripts-9.37.2-1.fc17.x86_64

How reproducible:
Manually invoking pppd doesn't honour "route-zzz" files in /etc/sysconfig/network-scripts - where "zzz" stands for the ppp peer name. This is because /etc/sysconfig/network-scripts/ifup-post tries to execute /etc/sysconfig/network-scripts/ifup-post as an external command.

Steps to Reproduce:
1. configure a ppp peer the "old-school" way, using /etc/ppp/peers, chap-secrets, etc
2. manually start pppd, using "pppd <peer_name>"
  
Actual results:
Custom routes defined in /etc/sysconfig/network-scripts/route-<peer_name> are not added.

Comment 1 Bill Nottingham 2012-12-10 17:48:52 UTC
This was accidentally changed in March. Fixed in git.

Comment 2 Fedora Update System 2013-02-21 09:08:23 UTC
initscripts-9.42.2-1.fc18, systemd-197-1.fc18.2 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-1590/initscripts-9.42.2-1.fc18,systemd-197-1.fc18.2

Comment 3 Fedora Update System 2013-02-23 01:03:43 UTC
Package initscripts-9.42.2-1.fc18, systemd-197-1.fc18.2:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initscripts-9.42.2-1.fc18 systemd-197-1.fc18.2'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1590/initscripts-9.42.2-1.fc18,systemd-197-1.fc18.2
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2013-02-26 02:45:39 UTC
initscripts-9.42.2-1.fc18, systemd-197-1.fc18.2 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.