Bug 886388

Summary: [abrt] libreoffice-core-3.5.7.2-6.fc17: ScRangeList::front: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Gabriel PREDA <gabriel>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: caolanm, dtardon, erack, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:7196d494f8785dc8efb0ab36a59d77d9d65681f8
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-19 10:34:36 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: core_backtrace
none
File: environ
none
File: var_log_messages
none
File: backtrace
none
File: limits
none
File: cgroup
none
File: smolt_data
none
File: executable
none
File: maps
none
File: dso_list
none
File: build_ids
none
File: proc_pid_status
none
File: open_fds none

Description Gabriel PREDA 2012-12-12 03:00:58 EST
Version-Release number of selected component:
libreoffice-core-3.5.7.2-6.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc --splash-pipe=6
crash_function: ScRangeList::front
kernel:         3.6.8-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 ScRangeList::front at /usr/src/debug/libreoffice-3.5.7.2/sc/source/core/tool/rangelst.cxx:548
: #1 ScDocument::GetClipStart at /usr/src/debug/libreoffice-3.5.7.2/sc/source/core/data/document.cxx:2771
: #2 ScViewFunc::PasteFromClip at /usr/src/debug/libreoffice-3.5.7.2/sc/source/ui/view/viewfun3.cxx:1215
: #3 ScClipUtil::PasteFromClipboard at /usr/src/debug/libreoffice-3.5.7.2/sc/source/ui/view/cliputil.cxx:87
: #4 ScCellShell::ExecuteEdit at /usr/src/debug/libreoffice-3.5.7.2/sc/source/ui/view/cellsh1.cxx:1174
: #5 CallExec at /usr/src/debug/libreoffice-3.5.7.2/sfx2/inc/sfx2/shell.hxx:201
: #6 SfxDispatcher::Call_Impl at /usr/src/debug/libreoffice-3.5.7.2/sfx2/source/control/dispatch.cxx:276
: #7 SfxBindings::Execute_Impl at /usr/src/debug/libreoffice-3.5.7.2/sfx2/source/control/bindings.cxx:1310
: #8 SfxDispatchController_Impl::dispatch at /usr/src/debug/libreoffice-3.5.7.2/sfx2/source/control/unoctitm.cxx:743
: #9 SfxOfficeDispatch::dispatch at /usr/src/debug/libreoffice-3.5.7.2/sfx2/source/control/unoctitm.cxx:375
Comment 1 Gabriel PREDA 2012-12-12 03:01:02 EST
Created attachment 662064 [details]
File: core_backtrace
Comment 2 Gabriel PREDA 2012-12-12 03:01:05 EST
Created attachment 662065 [details]
File: environ
Comment 3 Gabriel PREDA 2012-12-12 03:01:07 EST
Created attachment 662067 [details]
File: var_log_messages
Comment 4 Gabriel PREDA 2012-12-12 03:01:10 EST
Created attachment 662068 [details]
File: backtrace
Comment 5 Gabriel PREDA 2012-12-12 03:01:12 EST
Created attachment 662069 [details]
File: limits
Comment 6 Gabriel PREDA 2012-12-12 03:01:14 EST
Created attachment 662070 [details]
File: cgroup
Comment 7 Gabriel PREDA 2012-12-12 03:01:16 EST
Created attachment 662071 [details]
File: smolt_data
Comment 8 Gabriel PREDA 2012-12-12 03:01:18 EST
Created attachment 662072 [details]
File: executable
Comment 9 Gabriel PREDA 2012-12-12 03:01:20 EST
Created attachment 662073 [details]
File: maps
Comment 10 Gabriel PREDA 2012-12-12 03:01:23 EST
Created attachment 662074 [details]
File: dso_list
Comment 11 Gabriel PREDA 2012-12-12 03:01:26 EST
Created attachment 662075 [details]
File: build_ids
Comment 12 Gabriel PREDA 2012-12-12 03:01:28 EST
Created attachment 662076 [details]
File: proc_pid_status
Comment 13 Gabriel PREDA 2012-12-12 03:01:31 EST
Created attachment 662078 [details]
File: open_fds
Comment 14 Eike Rathke 2012-12-12 10:23:36 EST
@Gabriel:
Crash happened when pasting something from clipboard into Calc, is this somehow reproducible?
Comment 15 Gabriel PREDA 2012-12-12 11:05:29 EST
After several attempts I was not able to reproduce this one.

From what I recall I was copying from some cells and pasting into other cells (either CTRL+C & CTRL+V sequence or CTR+C & Enter).
Comment 16 Eike Rathke 2013-02-19 10:34:36 EST
Not reproducible, closing.