Bug 88641

Summary: xawtv crashes xfree86
Product: [Retired] Red Hat Linux Reporter: Need Real Name <kodis>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED CURRENTRELEASE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9Keywords: MoveUpstream
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
URL: http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=261
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-06-24 13:01:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2003-04-11 13:08:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Linux enters a hard hangup condition (no response to any of the Ctrl-Alt-magic
keys, no response to pings) shortly after running the xawtv program.  X works
fine with all other applications.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1.Start X; start xawtv; wait a few seconds; curse, cycle the power, fsck the disks.
2.
3.
    

Actual Results:  The box hangs until power-cycled.

Expected Results:  I want my MTV!

Additional info:

I suspect that this problem may be limited to the hardware that I'm using: a
Radeon 9000 Pro AGP video card (built by ATI, not just powered by ATI), and a
Haupage Win-TV card.  Here's what lspci finds:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS645DX Host & Memory &
AGP Controller
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS 530 Virtual PCI-to-PCI
bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO]
(rev 04)
00:02.3 FireWire (IEEE 1394): Silicon Integrated Systems [SiS] FireWire Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:03.0 USB Controller: Silicon Integrated Systems [SiS] SiS7001 USB Controller
(rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] SiS7001 USB Controller
(rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] SiS7001 USB Controller
(rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] SiS7002 USB 2.0
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100
Ethernet (rev 91)
00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:0a.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture
(rev 02)
00:0a.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 02)
00:0d.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 20)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 If [Radeon
9000] (rev 01)
01:00.1 Display controller: ATI Technologies Inc Radeon R250 [Radeon 9000]
(Secondary) (rev 01)
Comment 1 Mike A. Harris 2003-04-11 18:21:14 EDT
I don't have access to any Hauppauge hardware, so I won't be able to
investigate this problem.  Also, the problem could be some resource
conflict with your specific lineup of hardware, so it is a rather
complex type of problem to try to both reproduce and troubleshoot
that might require having the actual specific machine that is having
the problem.  It could even be a kernel bug, or even a hardware
flaw of some kind.

Even though there's nothing I can really do about this problem, I'll
leave the bug report open in case you acquire debugging information
that pinpoints the problem down, or in case someone else has the
same problem and can do so.

You may also want to report the problem on xfree86@xfree86.org mailing list
to get feedback from other users and X developers who might have advice
for you to try different things perhaps.
Comment 2 Mike A. Harris 2003-04-25 06:27:26 EDT
Please report this upstream at http://bugs.xfree86.org and provide the upstream
URL here, and I will track it and possibly backport any fixes.
Comment 3 Need Real Name 2003-05-13 14:59:21 EDT
I've found an interesting bit of information about this problem: it seems to be
limited to 24 bit color depths.  I've worked around the problem by switching to
a 16 bit color depth and have had no further difficulties.

I've also reported this problem upstream as requested.  The upstream bug url is
http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=261
Comment 4 Mike A. Harris 2003-05-15 23:37:43 EDT
Thanks, I've CC'd myself upstream and will keep track of both reports and
try to keep them in sync.
Comment 5 Mike A. Harris 2003-07-17 06:37:49 EDT
Status update: Upstream bug report untouched by upstream developers.
Comment 6 Mike A. Harris 2004-06-24 13:01:59 EDT
I've examined the upstream bug report and while it's still opened,
X has changed a lot since this report was initially filed, and it
is likely that the current X.Org X11R6.7.0 may resolve this issue.

I'm able to run xawtv on Fedora Core 1 with all updates applied on
a Radeon 9000 Pro, and Fedora Core 2 with the same card.  I don't
have the same motherboard, etc. nor the Haupauge card however,
and they may be related to the problem, so this isn't conclusive.

Please upgrade to Fedora Core 2, and if this problem is still present,
file a new bug report in X.Org bugzilla at http://www.freedesktop.org
in the 'xorg' component.

Closing as 'CURRENTRELEASE'.  Feel free to reopen if problem still
exists in FC2.

Thanks.