Bug 887926

Summary: [RFE] Add command to update cluster configuration using a standard editor (e. g. pcs config edit)
Product: Red Hat Enterprise Linux 6 Reporter: Frank Danapfel <fdanapfe>
Component: pcsAssignee: Chris Feist <cfeist>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.4CC: cfeist, cluster-maint, fdinitto, jharriga, rsteiger
Target Milestone: rcKeywords: FutureFeature
Target Release: 6.5   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: pcs-0.9.74-1.el6 Doc Type: Enhancement
Doc Text:
Feature: Add ability of pcs to edit cluster configuration with a standard editor Reason: This will save several steps, including the user saving the cib, editing it and then pushing it back to the cluster. Result (if any): Users can edit and update the cluster configuration in one step ('pcs cluster edit')
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-21 11:49:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Frank Danapfel 2012-12-17 15:58:32 UTC
It would be helpful if pcs had the option to edit and update the cluster configuration in one go, for example something like "pcs config edit"

This should open the current cluster configuration in text format in the users text editor (defined via the $EDITOR env. var.) and after the user saves the changed version pcs should check the updated config for any errors and if it is correct it should automatically be pushed out to all cluster nodes.

Comment 4 Chris Feist 2013-08-13 21:26:10 UTC
[root@ask-02 ~]# EDITOR=vim pcs -f temp.xml cluster edit

Pops open vim with the cib from temp.xml (or creates a new one if temp.xml doesn't exist).

Comment 8 errata-xmlrpc 2013-11-21 11:49:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1633.html