This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 888483

Summary: non-ASCII instance name breaks various nova commands
Product: Red Hat OpenStack Reporter: Russell Bryant <rbryant>
Component: python-novaclientAssignee: Flavio Percoco <fpercoco>
Status: CLOSED ERRATA QA Contact: Kashyap Chamarthy <kchamart>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.1CC: fpercoco, jhenner, jruzicka, zbitter
Target Milestone: snapshot5Keywords: i18n, Triaged
Target Release: 2.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-novaclient-2.10.0-7.el6ost Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-04 13:58:36 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Russell Bryant 2012-12-18 13:48:05 EST
Description of problem:

The 'nova show' command can take an argument of the instance UUID or an instance name.  If you created an instance with non-ASCII characters in the name, it breaks 'nova show'.


Version-Release number of selected component (if applicable):

python-novaclient-2.10.0-1.el6ost.noarch
openstack-nova-common-2012.2.1-2.el6ost.noarch
openstack-nova-compute-2012.2.1-2.el6ost.noarch
openstack-nova-scheduler-2012.2.1-2.el6ost.noarch
openstack-nova-novncproxy-0.4-2.el6.noarch
python-nova-2012.2.1-2.el6ost.noarch
openstack-nova-console-2012.2.1-2.el6ost.noarch
openstack-nova-api-2012.2.1-2.el6ost.noarch
openstack-nova-volume-2012.2.1-2.el6ost.noarch
openstack-nova-cert-2012.2.1-2.el6ost.noarch
openstack-nova-2012.2.1-2.el6ost.noarch
openstack-nova-network-2012.2.1-2.el6ost.noarch
openstack-nova-objectstore-2012.2.1-2.el6ost.noarch



How reproducible:

Every time


Steps to Reproduce:

[root@rhel ~(keystone_username)]# nova boot --flavor 1 --image 5701fd2f-d1cb-4bcb-bb5d-fa9e9a4bbd51 --key_name oskey "El Niño"
+------------------------+--------------------------------------+
| Property               | Value                                |
+------------------------+--------------------------------------+
| OS-DCF:diskConfig      | MANUAL                               |
| OS-EXT-STS:power_state | 0                                    |
| OS-EXT-STS:task_state  | scheduling                           |
| OS-EXT-STS:vm_state    | building                             |
| accessIPv4             |                                      |
| accessIPv6             |                                      |
| adminPass              | 9yDSAeXHjd85                         |
| config_drive           |                                      |
| created                | 2012-12-18T18:29:13Z                 |
| flavor                 | m1.tiny                              |
| hostId                 |                                      |
| id                     | 62af8324-ee9a-4b7a-b41f-be5fa75d91dc |
| image                  | f17-x86_64-openstack-sda             |
| key_name               | oskey                                |
| metadata               | {}                                   |
| name                   | El Niño                              |
| progress               | 0                                    |
| security_groups        | [{u'name': u'default'}]              |
| status                 | BUILD                                |
| tenant_id              | 34e9ef477d70492db00e28d130d5584c     |
| updated                | 2012-12-18T18:29:14Z                 |
| user_id                | 01d9cc70566849a39c3f0ab63622cb9d     |
+------------------------+--------------------------------------+
[root@rhel ~(keystone_username)]# nova list
+--------------------------------------+---------+--------+------------------+
| ID                                   | Name    | Status | Networks         |
+--------------------------------------+---------+--------+------------------+
| 62af8324-ee9a-4b7a-b41f-be5fa75d91dc | El Niño | BUILD  | demonet=10.0.0.2 |
+--------------------------------------+---------+--------+------------------+
[root@rhel ~(keystone_username)]# nova list
+--------------------------------------+---------+--------+------------------+
| ID                                   | Name    | Status | Networks         |
+--------------------------------------+---------+--------+------------------+
| 62af8324-ee9a-4b7a-b41f-be5fa75d91dc | El Niño | ACTIVE | demonet=10.0.0.2 |
+--------------------------------------+---------+--------+------------------+
[root@rhel ~(keystone_username)]# nova show 62af8324-ee9a-4b7a-b41f-be5fa75d91dc
+------------------------+-----------------------------------------------------------------+
| Property               | Value                                                           |
+------------------------+-----------------------------------------------------------------+
| OS-DCF:diskConfig      | MANUAL                                                          |
| OS-EXT-STS:power_state | 1                                                               |
| OS-EXT-STS:task_state  | None                                                            |
| OS-EXT-STS:vm_state    | active                                                          |
| accessIPv4             |                                                                 |
| accessIPv6             |                                                                 |
| config_drive           |                                                                 |
| created                | 2012-12-18T18:29:13Z                                            |
| demonet network        | 10.0.0.2                                                        |
| flavor                 | m1.tiny (1)                                                     |
| hostId                 | 6c39f880886229e4f4fad3c92111ef7b64c5673651b2addc428c7f0d        |
| id                     | 62af8324-ee9a-4b7a-b41f-be5fa75d91dc                            |
| image                  | f17-x86_64-openstack-sda (5701fd2f-d1cb-4bcb-bb5d-fa9e9a4bbd51) |
| key_name               | oskey                                                           |
| metadata               | {}                                                              |
| name                   | El Niño                                                         |
| progress               | 0                                                               |
| security_groups        | [{u'name': u'default'}]                                         |
| status                 | ACTIVE                                                          |
| tenant_id              | 34e9ef477d70492db00e28d130d5584c                                |
| updated                | 2012-12-18T18:30:30Z                                            |
| user_id                | 01d9cc70566849a39c3f0ab63622cb9d                                |
+------------------------+-----------------------------------------------------------------+
[root@rhel ~(keystone_username)]# nova show "El Niño"
/usr/lib/python2.6/site-packages/novaclient/base.py:199: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  for (attr, value) in searches):
Traceback (most recent call last):
  File "/usr/bin/nova", line 9, in <module>
    load_entry_point('python-novaclient==2.10.0', 'console_scripts', 'nova')()
  File "/usr/lib/python2.6/site-packages/novaclient/shell.py", line 544, in main
    print >> sys.stderr, "ERROR: %s" % unicode(e)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 37: ordinal not in range(128)
Comment 2 Russell Bryant 2012-12-18 14:15:27 EST
This breaks more than just 'nova show'.  The same root problem affects other commands too, such as 'nova reboot'.

[root@rhel ~(keystone_username)]# nova reboot "El Niño"
/usr/lib/python2.6/site-packages/novaclient/base.py:199: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  for (attr, value) in searches):
Traceback (most recent call last):
  File "/usr/bin/nova", line 9, in <module>
    load_entry_point('python-novaclient==2.10.0', 'console_scripts', 'nova')()
  File "/usr/lib/python2.6/site-packages/novaclient/shell.py", line 544, in main
    print >> sys.stderr, "ERROR: %s" % unicode(e)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 37: ordinal not in range(128)
Comment 7 Kashyap Chamarthy 2013-03-26 08:00:22 EDT
VERIFIED.

1] Version info:
#-------------#
$ cat /etc/redhat-release ; arch
Red Hat Enterprise Linux Server release 6.4 (Santiago)
x86_64

$ rpm -q python-novaclient --changelog | grep 888483
- Decodes input and encodes output. (#888483)
#-------------#


2] Try to boot the instance
#-------------#
$ nova boot --flavor 1 --key_name oskey3 --image 40497881-5a89-4c39-b3f7-5d22db2fee51 "El Niño"
+------------------------+--------------------------------------+
| Property               | Value                                |
+------------------------+--------------------------------------+
| status                 | BUILD                                |
| updated                | 2013-03-26T11:18:50Z                 |
| OS-EXT-STS:task_state  | scheduling                           |
| key_name               | oskey3                               |
| image                  | fedora-16                            |
| hostId                 |                                      |
| OS-EXT-STS:vm_state    | building                             |
| flavor                 | m1.tiny                              |
| id                     | cc920452-a407-47b7-a367-d4ff977017b7 |
| security_groups        | [{u'name': u'default'}]              |
| user_id                | 320ce46de7e24a75a7ff8906d7355ff7     |
| name                   | El Niño                              |
| adminPass              | XWkwBkb22vRx                         |
| tenant_id              | 57ff99aae24b4035b52177a722c4091f     |
| created                | 2013-03-26T11:18:50Z                 |
| OS-DCF:diskConfig      | MANUAL                               |
| accessIPv4             |                                      |
| accessIPv6             |                                      |
| progress               | 0                                    |
| OS-EXT-STS:power_state | 0                                    |
| metadata               | {}                                   |
| config_drive           |                                      |
+------------------------+--------------------------------------+
#-------------#


2.1] Try a few more:
#-------------#
$ nova boot --flavor 1 --key_name oskey3 --image 40497881-5a89-4c39-b3f7-5d22db2fee51 "äçë"
+------------------------+--------------------------------------+
| Property               | Value                                |
+------------------------+--------------------------------------+
| status                 | BUILD                                |
| updated                | 2013-03-26T11:59:52Z                 |
| OS-EXT-STS:task_state  | scheduling                           |
| key_name               | oskey3                               |
| image                  | fedora-16                            |
| hostId                 |                                      |
| OS-EXT-STS:vm_state    | building                             |
| flavor                 | m1.tiny                              |
| id                     | d0ee0b34-f9b1-4e57-a239-15d5e2e38036 |
| security_groups        | [{u'name': u'default'}]              |
| user_id                | 320ce46de7e24a75a7ff8906d7355ff7     |
| name                   | äçë                                  |
| adminPass              | Gyzv7GC8CCMH                         |
| tenant_id              | 57ff99aae24b4035b52177a722c4091f     |
| created                | 2013-03-26T11:59:51Z                 |
| OS-DCF:diskConfig      | MANUAL                               |
| accessIPv4             |                                      |
| accessIPv6             |                                      |
| progress               | 0                                    |
| OS-EXT-STS:power_state | 0                                    |
| metadata               | {}                                   |
| config_drive           |                                      |
+------------------------+--------------------------------------+
#-------------#


2.2] nova list
#-------------#
$ nova list | grep El
| cc920452-a407-47b7-a367-d4ff977017b7 | El Niño       | ACTIVE | net1=xx.yy.ww.56 |
#-------------#
$ nova list | grep äçë
| d0ee0b34-f9b1-4e57-a239-15d5e2e38036 | äçë           | ACTIVE | net1=xx.yy.ww.57 |
#-------------#


2.3]
$ nova show äçë
+------------------------+----------------------------------------------------------+
| Property               | Value                                                    |
+------------------------+----------------------------------------------------------+
| status                 | ACTIVE                                                   |
| updated                | 2013-03-26T12:00:07Z                                     |
| OS-EXT-STS:task_state  | None                                                     |
| key_name               | oskey3                                                   |
| image                  | fedora-16 (40497881-5a89-4c39-b3f7-5d22db2fee51)         |
| hostId                 | ea9a88283bae81eb0a5621a827995c8485a5fa60e13ca4be47ce90d6 |
| OS-EXT-STS:vm_state    | active                                                   |
| flavor                 | m1.tiny (1)                                              |
| id                     | d0ee0b34-f9b1-4e57-a239-15d5e2e38036                     |
| security_groups        | [{u'name': u'default'}]                                  |
| user_id                | 320ce46de7e24a75a7ff8906d7355ff7                         |
| name                   | äçë                                                      |
| created                | 2013-03-26T11:59:51Z                                     |
| tenant_id              | 57ff99aae24b4035b52177a722c4091f                         |
| OS-DCF:diskConfig      | MANUAL                                                   |
| accessIPv4             |                                                          |
| accessIPv6             |                                                          |
| net1 network           | xx.yy.ww.57                                             |
| progress               | 0                                                        |
| OS-EXT-STS:power_state | 1                                                        |
| metadata               | {}                                                       |
| config_drive           |                                                          |
+------------------------+----------------------------------------------------------+
Comment 9 errata-xmlrpc 2013-04-04 13:58:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0706.html