This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 888504

Summary: Horizon: language settings are not saved
Product: Red Hat OpenStack Reporter: Yaniv Kaul <ykaul>
Component: python-django-horizonAssignee: Matthias Runge <mrunge>
Status: CLOSED ERRATA QA Contact: Nir Magnezi <nmagnezi>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.0 (Folsom)CC: jkt, jpichon, mlopes, mrunge
Target Milestone: betaKeywords: i18n, Triaged
Target Release: 4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-django-horizon-2013.2-4.el6ost Doc Type: Bug Fix
Doc Text:
Prior to this update, the Dashboard cookie containing user preferences would not persist after logout. Consequently, user preferences such as language needed to be reconfigured. With this fix, the Dashboard cookie persists and user preferences are retained after logout.
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-12-19 18:53:36 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Yaniv Kaul 2012-12-18 14:35:22 EST
Description of problem:
When changing language (under Settings) to a different language, it seems to work and take place - but is not saved after logout-login.

(Note: time zone isn't saved either, related or a different BZ?)

Version-Release number of selected component (if applicable):
python-django-horizon-2012.2.1-2.el6ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Julie Pichon 2012-12-21 10:54:22 EST
Horizon doesn't use a database and doesn't persist any information. User settings such as the language and the timezone are stored in the cookie: if the user logs out then the cookie is lost and the information would need to be set again.

I think there are discussions about perhaps storing that kind of user-information in Keystone in the future, but I don't think it's going to happen soon.
Comment 6 Nir Magnezi 2013-11-28 10:31:54 EST
Verified NVR: python-django-horizon-2013.2-5.el6ost.noarch

Verification Steps:
===================
1. Changed Language, Timezone and Items Per Page in Settings page.
2. Logged out
3. Logged in

Result:
=======
All settings were saved.
Comment 9 errata-xmlrpc 2013-12-19 18:53:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html