Bug 888873

Summary: [or] pofilter tabs test failed for several msgids
Product: Red Hat Enterprise Linux 6 Reporter: John Sefler <jsefler>
Component: subscription-managerAssignee: candlepin-bugs
Status: CLOSED ERRATA QA Contact: IDM QE LIST <seceng-idm-qe-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.4CC: alikins, mgiri, tlavigne
Target Milestone: rcKeywords: Translation
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-21 04:05:09 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 771481    

Description John Sefler 2012-12-19 12:10:24 EST
Description of problem:

THE TRANSLATIONS SHOWN BELOW ARE FAILING THE pofilter tabs TEST.  WHEN TRANSLATIING A msgid, THE "\t" CHARACTERS SHOULD NOT BE STRIPPED OUT.

[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/or/LC_MESSAGES/rhsm.mo > /usr/share/locale/or/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/or/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2012-12-14 12:46-0500\n"
"Last-Translator: mgiri <mgiri@fedoraproject.org>\n"
"Language-Team: Oriya <oriya-it@googlegroups.com>\n"
"Language: or\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) tabs: Different tabs
msgid "Multi-Entitlement:    \t%s"
msgstr "ଏକାଧିକ-ଅଧିକାର: %s"

# (pofilter) tabs: Different tabs
msgid "Name:                 \t%s"
msgstr "ନାମ: %s"

# (pofilter) tabs: Different tabs
msgid "Pool Id:              \t%s"
msgstr "ପୁଲ Id: %s"

# (pofilter) tabs: Different tabs
msgid "Quantity:             \t%s"
msgstr "ପରିମାଣ: %s"

# (pofilter) tabs: Different tabs
msgid "Serial Number:        \t%s"
msgstr "କ୍ରମ ସଂଖ୍ୟା: %s"

# (pofilter) tabs: Different tabs
msgid "Starts:               \t%s"
msgstr "ଆରମ୍ଭ: %s"

# (pofilter) tabs: Different tabs
msgid "Status:               \t%s"
msgstr "ସ୍ଥିତି: %s"

# (pofilter) tabs: Different tabs
msgid "Version:              \t%s"
msgstr "ସଂସ୍କରଣ: %s"
[###########################################] 100%
[root@jsefler-6 ~]# 




Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
How reproducible:
Comment 2 Manoj Kumar Giri 2012-12-20 02:27:19 EST
Corrected the translation errors in subscription-manager 1.1.x.

Thanks,
Manoj
Comment 3 Adrian Likins 2013-01-04 13:35:40 EST
fixed upstream, should be 1.1.19
Comment 5 John Sefler 2013-01-07 16:11:51 EST
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/or/LC_MESSAGES/rhsm.mo > /usr/share/locale/or/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/or/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%



VERIFIED pofilter tabs test are now passing
Comment 7 errata-xmlrpc 2013-02-21 04:05:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html