Bug 889995

Summary: 'info qtree' outputs are different between "rhel6.0 host" and "rhel6.4 host with -M rhel6.0.0" (default parameters)
Product: Red Hat Enterprise Linux 6 Reporter: Qunfang Zhang <qzhang>
Component: qemu-kvmAssignee: Eduardo Habkost <ehabkost>
Status: CLOSED NOTABUG QA Contact: Virtualization Bugs <virt-bugs>
Severity: high Docs Contact:
Priority: high    
Version: 6.4CC: acathrow, amit.shah, areis, armbru, bsarathy, dyasny, juzhang, michen, mkenneth, rhod, shuang, virt-maint
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-21 11:27:55 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
'info qtree' output on rhel6.0 host with default paramters
none
'info qtree' output on rhel6.4 host (-M rhel6.0.0) with default paramters none

Description Qunfang Zhang 2012-12-24 04:56:41 EST
Description of problem:
Lots of properties that doesn't exist on  rhel6.0 host, appears on rhel6.4 host. Details please check the steps.

Version-Release number of selected component (if applicable):
RHEL6.4 host:
kernel2.6.32-348.el6.x86_64
qemu-kvm-0.12.1.2-2.346.el6.x86_64

RHEL6.0-z host:
kernel-2.6.32-71.40.1.el6.x86_64
qemu-kvm-0.12.1.2-2.113.el6_0.8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start a command line on rhel6.0-z host.
# /usr/libexec/qemu-kvm  -monitor stdio 

2. On rhel6.0-z host:
(qemu)info qtree

3. Start a command line on rhel6.4 host:
# /usr/libexec/qemu-kvm -M rhel6.0.0 -monitor stdio 

4. On rhel6.4 host:
(qemu)info qtree

5. Compare the output in step 2 and step 4.

  
Actual results:
Lots of properties that doesn't exist on  rhel6.0 host, appears on rhel6.4 host.

Expected results:


Additional info:

(a) -M rhel6.0.0 on rhel6.4 host, there's PIIX4_PM content while on rhel6.0 host, there's not.

  dev: PIIX4_PM, id "" 
        dev-prop: smb_io_base = 45312 
        dev-prop: disable_s3 = 1 
        dev-prop: disable_s4 = 1 
        dev-prop: s4_val = 2 
        bus-prop: addr = 01.3 
        bus-prop: romfile = <null> 
        bus-prop: rombar = 1 
        bus-prop: multifunction = off 
        class Bridge, addr 00:01.3, pci id 8086:7113 (sub 1af4:1100) 


(b)rhel6.4 host with -M rhel6.0.0,  the following devices have "bus-prop: multifunction = off", rhel6.0 has not.
dev: piix3-ide 
dev: rtl8139
dev: cirrus-vga

(c) dev: ide-drive, rhel6.4 host have the following property while rhel6.0 has not.
  dev-prop: bootindex = -1 
  dev-prop: discard_granularity = 0 
  dev-prop: wwn = 0x0 

(d)dev: rtl8139: rhel6.4 host have the following property while rhel6.0 has not.

dev-prop: bootindex = -1

(e) dev: PIIX3, rhel6.4 host have the following property while rhel6.0 has not.

bus-prop: multifunction = on 

(f)"dev: isa-fdc" under "dev: PIIX3", rhel6.4 host have the following property while rhel6.0 has not.

 dev-prop: bootindexA = -1 
 dev-prop: bootindexB = -1 
 dev-prop: migrate_dir = 0 

(g)"dev: isa-serial" under "dev: PIIX3", rhel6.4 host have the following property while rhel6.0 has not.

dev-prop: wakeup = 0


(h)"dev: i440FX" under "dev: PIIX3", rhel6.4 host have the following property while rhel6.0 has not.

bus-prop: multifunction = off
Comment 1 Qunfang Zhang 2012-12-24 04:58:02 EST
Created attachment 668423 [details]
'info qtree' output on rhel6.0 host with default paramters
Comment 2 Qunfang Zhang 2012-12-24 04:58:36 EST
Created attachment 668426 [details]
'info qtree' output on rhel6.4 host (-M rhel6.0.0) with default paramters
Comment 6 Qunfang Zhang 2012-12-24 05:34:44 EST
Just talked with Amit, there are many properties showing up on rhel6.4 host with -M rhel6.0.0. Maybe some are real bugs and some are not. Maybe it makes sense to separate them but actually I'm not sure how to draw the line. So I create one bugs to track all of them. Please add comments and we will get better understanding.
Comment 7 Eduardo Habkost 2012-12-26 08:14:38 EST
Having new property exposed on the newer qemu versions is completely expected. What can't change is the guest-visible side: the guest-visible state and guest-visible behavior can't change when using the older machine-types.

Auditing every single property will consume some time and will require help from people with experience in each part of the QEMU code. I don't believe we should make this a blocker bug as this isn't even a real bug, unless we find an actual issue during the audit.
Comment 8 Eduardo Habkost 2012-12-26 12:05:06 EST
About sorting the bugs, I suggest we do the following:

- First, unify the 8 bugs in only one (or maybe 2: one for the "default parameters" ones, and another for the "non-default devices" ones). There's no point tracking each machine-type in a separate bug.
- Do _not_ mark those generic bugs as blockers, because we don't have confirmation of any real bug. They are only a request for an audit of the differences that were found (and are expected to exist), to try to find real bugs.
- Open separate bugs for each case where there is a real bug, or for specific areas where we need help from developers (e.g. we can probably have separate bugs for the USB and QXL differences found in bug 890121)
Comment 9 Eduardo Habkost 2012-12-26 12:07:17 EST
*** Bug 890018 has been marked as a duplicate of this bug. ***
Comment 10 Eduardo Habkost 2012-12-26 12:07:32 EST
*** Bug 890112 has been marked as a duplicate of this bug. ***
Comment 11 Eduardo Habkost 2012-12-26 12:07:35 EST
*** Bug 890117 has been marked as a duplicate of this bug. ***
Comment 12 Eduardo Habkost 2012-12-26 12:10:32 EST
Clearning "blocker" flag. There's no point in marking the bug as blocker if we didn't really find any actual bug. Having new properties added to the newer qemu-kvm version is completely expected.
Comment 13 Ademar Reis 2012-12-28 12:53:22 EST
Needinfo added by mistake? Clearing it.