Bug 890041

Summary: Quantum network node missing dnsmasq with installation
Product: Red Hat OpenStack Reporter: Gary Kotton <gkotton>
Component: openstack-quantumAssignee: Terry Wilson <twilson>
Status: CLOSED ERRATA QA Contact: Ofer Blaut <oblaut>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.0 (Folsom)CC: rkukura, twilson, ykaul
Target Milestone: snapshot2Keywords: Triaged
Target Release: 2.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-quantum-2012.2.1-5.el6ost Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-14 13:24:21 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 892339    
Attachments:
Description Flags
Add dnsmasq Require...for now
none
Fix version and remove extraneous README change none

Description Gary Kotton 2012-12-24 09:31:13 EST
Description of problem:
When just instaklling the Quantum packages (openstack-quantum) for the DHCP agent and L3 agent. The package for dnsmasq is not installed

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install quantum
2. Run DHCP agent
3. Look in log file
  
Actual results:


Expected results:


Additional info:
Command: ['sudo', 'quantum-rootwrap', '/etc/quantum/rootwrap.conf', 'QUANTUM_RELAY_SOCKET_PATH=/var/lib/quantum/dhcp/lease_relay', 'QUANTUM_NETWORK_ID=c9de7948-678b-4d3d-8748-69b603bac8bd', 'dnsmasq', '--no-hosts', '--no-resolv', '--strict-order', '--bind-interfaces', '--interface=tapf25bc932-98', '--except-interface=lo', '--domain=openstacklocal', '--pid-file=/var/lib/quantum/dhcp/c9de7948-678b-4d3d-8748-69b603bac8bd/pid', '--dhcp-hostsfile=/var/lib/quantum/dhcp/c9de7948-678b-4d3d-8748-69b603bac8bd/host', '--dhcp-optsfile=/var/lib/quantum/dhcp/c9de7948-678b-4d3d-8748-69b603bac8bd/opts', '--dhcp-script=/usr/bin/quantum-dhcp-agent-dnsmasq-lease-update', '--leasefile-ro', '--dhcp-range=set:tag0,10.0.0.0,static,120s']
Exit code: 1
Stdout: ''
Stderr: 'Traceback (most recent call last):\n  File "/usr/bin/quantum-rootwrap", line 95, in <module>\n    env=filtermatch.get_environment(userargs))\n  File "/usr/lib64/python2.6/subprocess.py", line 639, in __init__\n    errread, errwrite)\n  File "/usr/lib64/python2.6/subprocess.py", line 1228, in _execute_child\n    raise child_exception\nOSError: [Errno 2] No such file or directory\n'
2012-12-24 16:13:26     INFO [quantum.agent.dhcp_agent] Synchronizing state
2012-12-24 16:13:26    ERROR [quantum.agent.dhcp_agent] Unable to enable dhcp.
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/quantum/agent/dhcp_agent.py", line 91, in call_driver
    getattr(driver, action)()
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/dhcp.py", line 112, in enable
    self.spawn_process()
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/dhcp.py", line 261, in spawn_process
    utils.execute(cmd, self.root_helper)
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/utils.py", line 63, in execute
    raise RuntimeError(m)
RuntimeError:


And:

[root@gkotton-rhel64-2 ~]# sudo QUANTUM_RELAY_SOCKET_PATH=/var/lib/quantum/dhcp/lease_relay QUANTUM_NETWORK_ID=c9de7948-678b-4d3d-8748-69b603bac8bd dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapf25bc932-98 --except-interface=lo --domain=openstacklocal --pid-file=/var/lib/quantum/dhcp/c9de7948-678b-4d3d-8748-69b603bac8bd/pid --dhcp-hostsfile=/var/lib/quantum/dhcp/c9de7948-678b-4d3d-8748-69b603bac8bd/host --dhcp-optsfile=/var/lib/quantum/dhcp/c9de7948-678b-4d3d-8748-69b603bac8bd/opts --dhcp-script=/usr/bin/quantum-dhcp-agent-dnsmasq-lease-update --leasefile-ro --dhcp-range=tag0,10.0.0.0,static,120s
sudo: dnsmasq: command not found
Comment 2 Terry Wilson 2013-01-28 15:13:40 EST
Created attachment 689307 [details]
Add dnsmasq Require...for now
Comment 3 Terry Wilson 2013-01-28 15:24:39 EST
Created attachment 689311 [details]
Fix version and remove extraneous README change
Comment 4 Bob Kukura 2013-01-28 17:02:33 EST
Fixed package openstack-quantum-2012.2.1-5.el6ost is in brew.
Comment 6 Ofer Blaut 2013-02-06 07:01:13 EST
new installation install dnsmasq by itself 
openstack-quantum-2012.2.1-6.el6ost.noarch



rpm -qR openstack-quantum-2012.2.1-6.el6ost.noarch
/bin/bash  
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/usr/bin/env  
chkconfig  
chkconfig  
config(openstack-quantum) = 2012.2.1-6.el6ost
dnsmasq  
initscripts  
initscripts  
openstack-utils  
python-keystone  
python-quantum = 2012.2.1-6.el6ost
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
shadow-utils  
rpmlib(PayloadIsXz) <= 5.2-1
Comment 8 errata-xmlrpc 2013-02-14 13:24:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0260.html