This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 890117

Summary: 'info qtree' outputs are different between "rhel6.2 host" and "rhel6.4 host with -M rhel6.2.0" (default parameters)
Product: Red Hat Enterprise Linux 6 Reporter: Qunfang Zhang <qzhang>
Component: qemu-kvmAssignee: Eduardo Habkost <ehabkost>
Status: CLOSED DUPLICATE QA Contact: Virtualization Bugs <virt-bugs>
Severity: high Docs Contact:
Priority: high    
Version: 6.4CC: acathrow, amit.shah, areis, armbru, bsarathy, dyasny, juzhang, michen, mkenneth, rhod, shuang, virt-maint
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-26 12:07:34 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
'info qtree' output on rhel6.2 host with default paramters
none
'info qtree' output on rhel6.4 host (-M rhel6.2.0) with default paramters none

Description Qunfang Zhang 2012-12-25 03:04:43 EST
Description of problem:
(Similar with bug  890112, separate it to track -M rhel6.2.0 machine type.)
Lots of properties that doesn't exist on  rhel6.2 host, appears on rhel6.4 host when boot with -M rhel6.2.0. Details please check the steps.

Version-Release number of selected component (if applicable):
RHEL6.4 host:
kernel2.6.32-348.el6.x86_64
qemu-kvm-0.12.1.2-2.346.el6.x86_64

RHEL6.2-z host:
kernel-2.6.32-220.30.1.el6.x86_64
qemu-kvm-0.12.1.2-2.209.el6_2.5.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start a command line on rhel6.2-z host.
# /usr/libexec/qemu-kvm  -monitor stdio 

2. On rhel6.2-z host:
(qemu)info qtree

3. Start a command line on rhel6.4 host:
# /usr/libexec/qemu-kvm -M rhel6.2.0 -monitor stdio 

4. On rhel6.4 host:
(qemu)info qtree

5. Compare the output in step 2 and step 4.
  
Actual results:
Lots of properties that doesn't exist on  rhel6.2 host, appears on rhel6.4 host when boot with -M rhel6.2.0. Please check the additional info.

Expected results:
The "info qtree" output should be the same on the two hosts.

Additional info:

a) "dev: PIIX4_PM", rhel6.4 host with -M rhel6.2.0 has the following properties while rhel6.2 has not.
dev-prop: disable_s3 = 1 
dev-prop: disable_s4 = 1 
dev-prop: s4_val = 2 

(b) "dev: ide-drive" under "dev: piix3-ide", following property are showing up on rhel6.4 host while not exist on rhel6.2 host.

dev-prop: wwn = 0x0

(c) "dev: isa-fdc" under "dev: PIIX3",  following property are showing up on rhel6.4 host while not exist on rhel6.2 host.

dev-prop: migrate_dir = 0

(d) "dev: isa-seria" under "dev: PIIX3", following property are showing up on rhel6.4 host while not exist on rhel6.2 host.

dev-prop: wakeup = 0
Comment 1 Qunfang Zhang 2012-12-25 03:08:55 EST
Created attachment 668779 [details]
'info qtree' output on rhel6.2 host with default paramters
Comment 2 Qunfang Zhang 2012-12-25 03:09:46 EST
Created attachment 668780 [details]
'info qtree' output on rhel6.4 host (-M rhel6.2.0) with default paramters
Comment 3 Eduardo Habkost 2012-12-26 08:19:17 EST
Copying comment added to bug 889995:

Having new property exposed on the newer qemu versions is completely expected. What can't change is the guest-visible side: the guest-visible state and guest-visible behavior can't change when using the older machine-types.

Auditing every single property will consume some time and will require help from people with experience in each part of the QEMU code. I don't believe we should make this a blocker bug as this isn't even a real bug, unless we find an actual issue during the audit.
Comment 4 Eduardo Habkost 2012-12-26 12:07:34 EST
Unifying bugs. See bug 889995 comment #8.

*** This bug has been marked as a duplicate of bug 889995 ***