Bug 890176

Summary: Nova CLI help command use server definition instead of instance
Product: Red Hat OpenStack Reporter: Ofer Blaut <oblaut>
Component: python-novaclientAssignee: Jakub Ruzicka <jruzicka>
Status: CLOSED CANTFIX QA Contact: Vladan Popovic <vpopovic>
Severity: low Docs Contact:
Priority: low    
Version: 2.0 (Folsom)CC: apevec, dallan, dron, jruzicka, mlopes, ndipanov, sclewis
Target Milestone: z2Keywords: OtherQA, Triaged, ZStream
Target Release: 4.0   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: python-novaclient-2.15.0-2.el6ost Doc Type: Enhancement
Doc Text:
With this enhancement, the nova client more consistently uses the term 'server' in help text. Previously, the terms 'server' and 'instance' were used interchangeably.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-12 11:17:30 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ofer Blaut 2012-12-25 09:18:14 EST
Description of problem:

Thera are few nova CLI commands that use SERVER term instead of Instance 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.run (keystone_admin)]$ nova | grep server
2. you will get all the command using server definition 
Actual results:

Expected results:

no server should be used only instance 

Additional info:
Comment 2 Nikola Dipanov 2013-01-04 09:14:58 EST
Moving this to python-novaclient.

This is easy to fix as all the nova help is generated from docstrings of do_* functions in the shell.py. Should be fixed upstream first.

Note that terms 'server' and 'instance' are used interchangeably throughout the nova codebase, and don't necessarily cause confusion as they are not ambiguous. Having said that  - it makes sense to refer to the same thing by the same name at least in the command line utility.
Comment 3 Jakub Ruzicka 2013-03-18 10:56:23 EDT
I filled upstream bug for this:

Comment 5 Jakub Ruzicka 2013-09-23 10:06:22 EDT
*** Bug 976437 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Ruzicka 2013-09-24 04:40:23 EDT
Fix has been merged upstream. It will be included in next python-novaclient build.
Comment 13 Jakub Ruzicka 2014-01-08 10:52:41 EST
Fix backported.
Comment 14 Scott Lewis 2014-01-14 11:24:00 EST
Updating Target Milestone for bug in erratum
Comment 15 Vladan Popovic 2014-01-20 11:31:36 EST
Tested it on RHEL (RHOS-4.0) and it still has some occurrences of "instance" in host-evacuate and host-meta which were added upstream after the patch got merged.

$ rpm -q python-novaclient

$ nova help | grep instance
                        Update the VPN IP/port of a cloudpipe instance.
    cloudpipe-create    Create a cloudpipe instance for the given project.
    cloudpipe-list      Print a list of all cloudpipe instances.
    host-meta           Set or Delete metadata on all instances of a host.
    instance-action     Show an action.
    host-evacuate       Evacuate all instances from failed host to specified
                        Migrate all instances of the specified host to other
Comment 16 Jakub Ruzicka 2014-01-20 11:49:23 EST
So I fixed this upstream but 2 mentions of "instance" were added since then with new upstream patches. Given the circumstances I'd still consider this bug fixed.
Comment 19 Jakub Ruzicka 2014-02-12 11:17:30 EST
As Russel confirmed, "server" is predominant usage throughout OpenStack, also favoured in the upstream bug comment.

Anyway, this isn't a matter of choosing a correct term. I changed all viable "instance" to "server" upstream and yet new "instance" strings appeared with new upstream patches. In other words, this is upstream matter which must be solved there. The burden of correcting these downstream is *not* worth the gain.

To really fix this, convention would need to be chosen and enforced upstream.