Bug 890755

Summary: cannot create linear raid
Product: [Fedora] Fedora Reporter: Chris Murphy <bugzilla>
Component: system-storage-managerAssignee: Lukáš Czerner <lczerner>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: lczerner
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-31 12:50:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Murphy 2012-12-29 17:34:18 UTC
Description of problem:
Unable to create a linear/concat raid.

Version-Release number of selected component (if applicable):
system-storage-manager-0.2-1.fc18.noarch

How reproducible:
Always

Steps to Reproduce:
ssm -v create -r linear --fstype ext4 /dev/sdb /dev/sdc /dev/sde
ssm -v create -r --fstype ext4 /dev/sdb /dev/sdc /dev/sde
  
Actual results:
ssm create: error: argument -r/--raid: invalid choice: 'linear' (choose from '0', '1', '10')

ssm create: error: argument -r/--raid: expected one argument

Expected results:
man page says for -r "This is optional and if no specified, linear volume will be created."

Additional info:
Guessing linear raid is presently only supportable through LVM and Btrfs, rather than md. So this may be a feature request to support all three.

Comment 1 Lukáš Czerner 2013-07-31 12:50:45 UTC
As man page says for -r "This is optional and if no specified, linear volume will be created."

so if you do not specify -r then you have linear "raid" or rather JBOD as there is no "redundancy".

# ssm -v create --fstype ext4 /dev/sdb /dev/sdc /dev/sda
# ssm list | grep lvol001
/dev/lvm_pool/lvol001  lvm_pool    199.99 GB  ext4  199.99 GB  186.67 GB  linear

This is not a bug.

Thanks!
-Lukas