Bug 891197

Summary: nodejs-init-package-json - A node module to get your node module started
Product: [Fedora] Fedora Reporter: T.C. Hollingsworth <tchollingsworth>
Component: Package ReviewAssignee: Miro Hrončok <mhroncok>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: mhroncok, misc, notting, package-review
Target Milestone: ---Flags: mhroncok: fedora‑review+
limburgher: fedora‑cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-15 04:34:40 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 891221, 891223, 891226, 891235    
Bug Blocks: 891171    

Description T.C. Hollingsworth 2013-01-02 03:24:06 EST
Spec: http://patches.fedorapeople.org/npm/nodejs-init-package-json.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-init-package-json-0.0.7-1.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4830993
FAS username: patches

A node module to get your node module started.

This package is part of the npm stack and a future F19 Feature for Node.js.

This package may depend on other packages in the npm stack that aren't explicitly
listed as dependencies of this bug.  For more information, see bug 891171.

Please use nodejs-0.6.5-3 or later when building or using this package.
Comment 1 T.C. Hollingsworth 2013-01-10 02:37:38 EST
Updated with empty %build sections and other issues found in various reviews.

Spec: http://patches.fedorapeople.org/npm/nodejs-init-package-json.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-init-package-json-0.0.7-2.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4854328
Comment 2 Miro Hrončok 2013-01-10 14:33:28 EST
Description and Summary OK.

MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.

$ rpmlint ../SRPMS/nodejs-init-package-json-0.0.7-2.fc18.src.rpm ../RPMS/noarch/nodejs-init-package-json-0.0.7-2.fc18.noarch.rpm
nodejs-init-package-json.src: W: spelling-error %description -l en_US metadata -> meta data, meta-data, metatarsi
nodejs-init-package-json.noarch: W: spelling-error %description -l en_US metadata -> meta data, meta-data, metatarsi
nodejs-init-package-json.noarch: W: only-non-binary-in-usr-lib
nodejs-init-package-json.noarch: W: dangling-symlink /usr/lib/node_modules/init-package-json/node_modules/read-package-json /usr/lib/node_modules/read-package-json
nodejs-init-package-json.noarch: W: dangling-symlink /usr/lib/node_modules/init-package-json/node_modules/read /usr/lib/node_modules/read
nodejs-init-package-json.noarch: W: dangling-symlink /usr/lib/node_modules/init-package-json/node_modules/promzard /usr/lib/node_modules/promzard
nodejs-init-package-json.noarch: W: dangling-symlink /usr/lib/node_modules/init-package-json/node_modules/semver /usr/lib/node_modules/semver
2 packages and 0 specfiles checked; 0 errors, 7 warnings.

All are false positive. Symlinks OK, package requires (among others) npm(read-package-json), npm(semver), npm(promzard), npm(read). OK

MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption. OK
MUST: The package must meet the Packaging Guidelines. OK
MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines. OK
MUST: The License field in the package spec file must match the actual license.

Checked in package.json: BSD. OK

MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc. OK
MUST: The spec file must be written in American English. OK
MUST: The spec file for the package MUST be legible. OK
MUST: The sources used to build the package must match the upstream source, as provided in the spec URL.

$ sha256sum ../SOURCES/init-package-json-0.0.7.tgz 
49bb2b928df52c81ae832afa97c7ded5e63a9cd9062109c06bd864e055e99386  ../SOURCES/init-package-json-0.0.7.tgz
$ wget https://registry.npmjs.org/init-package-json/-/init-package-json-0.0.7.tgz --no-check-certificate
$ sha256sum init-package-json-0.0.7.tgz 
49bb2b928df52c81ae832afa97c7ded5e63a9cd9062109c06bd864e055e99386  init-package-json-0.0.7.tgz

OK

FIX: The Source0 URL should use http, not https

MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture. OK
MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. OK, builds in mock
MUST: Packages must NOT bundle copies of system libraries. OK
MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory. OK
MUST: A Fedora package must not list a file more than once in the spec file's %files listings. OK
MUST: Permissions on files must be set properly.

$ rpm -q -lv -p ../RPMS/noarch/nodejs-init-package-json-0.0.7-2.fc18.noarch.rpm 
drwxr-xr-x    2 root    root                        0 led 10 20:20 /usr/lib/node_modules/init-package-json
-rw-r--r--    1 root    root                     4695 lis  8 00:00 /usr/lib/node_modules/init-package-json/default-input.js
-rw-r--r--    1 root    root                     3048 čec 24 10:16 /usr/lib/node_modules/init-package-json/init-package-json.js
drwxr-xr-x    2 root    root                        0 led 10 20:20 /usr/lib/node_modules/init-package-json/node_modules
lrwxrwxrwx    1 root    root                       30 led 10 20:20 /usr/lib/node_modules/init-package-json/node_modules/promzard -> /usr/lib/node_modules/promzard
lrwxrwxrwx    1 root    root                       26 led 10 20:20 /usr/lib/node_modules/init-package-json/node_modules/read -> /usr/lib/node_modules/read
lrwxrwxrwx    1 root    root                       39 led 10 20:20 /usr/lib/node_modules/init-package-json/node_modules/read-package-json -> /usr/lib/node_modules/read-package-json
lrwxrwxrwx    1 root    root                       28 led 10 20:20 /usr/lib/node_modules/init-package-json/node_modules/semver -> /usr/lib/node_modules/semver
-rw-r--r--    1 root    root                      719 lis  8 00:00 /usr/lib/node_modules/init-package-json/package.json
drwxr-xr-x    2 root    root                        0 led 10 20:20 /usr/share/doc/nodejs-init-package-json-0.0.7
-rw-r--r--    1 root    root                     1169 čen 17  2012 /usr/share/doc/nodejs-init-package-json-0.0.7/README.md
-rw-r--r--    1 root    root                      362 čen 17  2012 /usr/share/doc/nodejs-init-package-json-0.0.7/example.js

OK

MUST: Each package must consistently use macros. OK
MUST: The package must contain code, or permissable content. OK
MUST: If a package includes something as %doc, it must not affect the runtime of the application. OK
MUST: Packages must not own files or directories already owned by other packages. OK
MUST: All filenames in rpm packages must be valid UTF-8. OK
SHOULD: If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it.

TODO: Query the upstream to include LICENSE file.

SHOULD: The reviewer should test that the package builds in mock. OK
SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself. OK

TODO: There are tests in the package, why not run them in %check section? In case you do this, don't forget to add all required modules (tap) as BRs.

Please, solve FIX and consider solving TODOs.

Package NEEDSWORK.
Comment 3 T.C. Hollingsworth 2013-01-13 08:20:26 EST
Source0 issue is fixed in this version:
Spec: http://patches.fedorapeople.org/npm/nodejs-init-package-json.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-init-package-json-0.0.7-3.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4864582

As mentioned previously, tests are currently disabled because tap is not yet in Fedora.  I just finished up the reviews for it and CCed you on the main one.
Comment 4 Miro Hrončok 2013-01-13 13:45:45 EST
Package APPROVED.
Comment 5 T.C. Hollingsworth 2013-01-13 16:33:24 EST
New Package SCM Request
=======================
Package Name: nodejs-init-package-json
Short Description: A node module to get your node module started
Owners: patches
Branches: f18 el6
InitialCC:
Comment 6 Jon Ciesla 2013-01-14 07:05:08 EST
Git done (by process-git-requests).
Comment 7 Fedora Update System 2013-04-05 19:16:15 EDT
node-gyp-0.9.1-2.fc18, nodejs-async-0.2.6-1.fc18, nodejs-chmodr-0.1.0-2.fc18, nodejs-fstream-npm-0.1.4-1.fc18, nodejs-glob-3.1.21-1.fc18, nodejs-minimatch-0.2.11-1.fc18, nodejs-mkdirp-0.3.5-1.fc18, nodejs-npm-registry-client-0.2.18-2.fc18, nodejs-read-package-json-0.2.2-1.fc18, nodejs-request-2.14.0-1.fc18, nodejs-semver-1.1.4-1.fc18, npm-1.2.14-2.fc18, nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-once-1.1.1-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-promzard-0.2.0-3.fc18, nodejs-combined-stream-0.0.4-1.fc18, nodejs-config-chain-1.1.5-1.fc18, nodejs-fstream-0.1.22-1.fc18, nodejs-fstream-ignore-0.0.6-1.fc18, nodejs-graceful-fs-1.2.0-1.fc18, nodejs-ini-1.1.0-1.fc18, nodejs-lockfile-0.3.0-1.fc18, nodejs-lru-cache-2.2.2-1.fc18, nodejs-mime-1.2.9-1.fc18, nodejs-nopt-2.1.1-1.fc18, nodejs-npmconf-0.0.23-1.fc18, nodejs-read-installed-0.1.1-1.fc18, nodejs-rimraf-2.1.4-1.fc18, nodejs-tar-0.1.16-1.fc18, nodejs-form-data-0.0.7-1.fc18 has been pushed to the Fedora 18 stable repository.