Bug 891294

Summary: Problems with the display of software origins
Product: [Fedora] Fedora Reporter: Mustafa Muhammad <mustafa1024m>
Component: apperAssignee: Rex Dieter <rdieter>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dantti12, kevin, ltinkl, rdieter, rhughes, smparrish
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-18 20:52:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mustafa Muhammad 2013-01-02 13:50:42 UTC
Description of problem:
The display of software origins has some problems, e.g.
1) when I tick in front of a repository to select/deselect it, it sometimes revert back in a second.
2) When I select "Show origins of debug and development packages" it shows them, then I go back (out of settings), next time I enter settings I have it is still selected but the corresponding repos are not shown.

Version-Release number of selected component (if applicable):
8.0

How reproducible:
Always

Steps to Reproduce:
1. Select "Show origins of debug and development packages"
2. Go out f settings
3. Enter the settings->Software origins again
  
Actual results:
"Show origins of debug and development packages" ticked but the corrensponding repos are not shown.

Expected results:
"Show origins of debug and development packages" ticked but the corrensponding repos are shown.

Additional info:

Comment 1 Daniel Nicoletti 2013-01-05 15:16:16 UTC
The second issue is fixed: http://commits.kde.org/apper/b3410a124e19a5d904aa37bd308c4233ebc69e53

I can't reproduce the first one.

Comment 2 Fedora Update System 2013-01-07 14:16:57 UTC
apper-0.8.0-0.13.20121231git.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-0094/apper-0.8.0-0.13.20121231git.fc18

Comment 3 Mustafa Muhammad 2013-01-07 18:02:28 UTC
(In reply to comment #1)
> The second issue is fixed:
> http://commits.kde.org/apper/b3410a124e19a5d904aa37bd308c4233ebc69e53

Thanks for your hard work.

> I can't reproduce the first one.

It happened sometime, but now I couldn't reproduce it!!!
You can mark it as closed, if it happened again, I will report it again.
Thank you very much.

Comment 4 Fedora Update System 2013-01-07 21:21:43 UTC
Package apper-0.8.0-0.13.20121231git.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apper-0.8.0-0.13.20121231git.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0094/apper-0.8.0-0.13.20121231git.fc18
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-01-09 22:55:29 UTC
Package apper-0.8.0-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apper-0.8.0-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0094/apper-0.8.0-2.fc18
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-01-18 20:52:57 UTC
apper-0.8.0-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.