Bug 891302

Summary: Horizon doesn't display proper error when Quantum quota exceeded while creating networks
Product: Red Hat OpenStack Reporter: Ofer Blaut <oblaut>
Component: python-django-horizonAssignee: Julie Pichon <jpichon>
Status: CLOSED ERRATA QA Contact: Ofer Blaut <oblaut>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.1CC: aortega, athomas, gkotton, jhenner, jpichon, mrunge, pbrady
Target Milestone: asyncKeywords: Triaged
Target Release: 2.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-django-horizon-2012.2.3-7.el6ost Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 927299 (view as bug list) Environment:
Last Closed: 2013-04-04 13:58:59 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Ofer Blaut 2013-01-02 09:17:52 EST
Description of problem:
Horizon doesn't display proper error when Quantum quote exceeded 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.configure quantum to use quotes
( http://docs.openstack.org/folsom/openstack-network/admin/content/cfg_quotas_common.html )

2. configure amount of network to  exceeded  quote via horizon 
3. check error output 
  
Actual results:

Error by  horizon : Failed to create 

Expected results:

Error by CLI : "Quota exceeded for resources: ['network'] "

Additional info:
Comment 2 Julie Pichon 2013-01-16 06:29:14 EST
There is an upstream bug to try to make error messages relating to quotas more consistent across Horizon, this is another one to add to the list.
Comment 3 Julie Pichon 2013-02-18 08:45:00 EST
Although the upstream bug on making quotas more consistent in general hasn't been resolved yet, the error message for this particular quota is different on upstream master and more useful:

Error: Failed to create network "test": Quota exceeded for resources: ['network']

I'll see if it's possible and reasonable to extract and backport the change.
Comment 7 Ofer Blaut 2013-03-20 06:00:51 EDT
Issue still occurs in python-django-horizon-2012.2.3-8.el6ost.noarch


creating 10 subnets on the same network :

Error: Failed to create subnet 30.1.7.0/24, nothing about Quota
Comment 8 Julie Pichon 2013-03-20 07:05:50 EDT
Thanks for the additional information Ofer. The initial bug report described an issue when creating new networks, which the patch focused on fixing. I agree the error handling should be more consistent though. Fixing this also for subnets can probably be done later in async in a separate bug, or if that's not acceptable I guess we can move this one out. I don't think it's a blocker. (For the record it's fixed in Grizzly.)
Comment 9 Lon Hohberger 2013-03-25 11:22:32 EDT
If the original issue is resolved, let's split the additional bug off.
Comment 12 Ofer Blaut 2013-04-02 08:19:02 EDT
ok, there is new bug for better error report 
https://bugzilla.redhat.com/show_bug.cgi?id=927299
Comment 14 errata-xmlrpc 2013-04-04 13:58:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0706.html