Bug 89151

Summary: Terminal hangs and hogs CPU when running make menuconfig on a 2.5 kernel tree
Product: [Retired] Red Hat Linux Reporter: Antonio Vargas <wind>
Component: vteAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: kas, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-05 03:23:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Complete list of installed packages none

Description Antonio Vargas 2003-04-18 13:40:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.2.1) Gecko/20030225

Description of problem:


Version-Release number of selected component (if applicable):
gnome-terminal-2.2.1-3

How reproducible:
Always

Steps to Reproduce:
1. unpack a 2.5 kernel tree somewhere
2. goto directory
3. make menuconfig
4. drill down 2 or 3 times
5. press exit several time to get back to main menu

    

Actual Results:  The terminal hangs

Expected Results:  Get back to the main menu just like when first entering it.

Additional info:

Tried both with and without AA fonts on gnome-terminal, it failed always.

Tried the same on xterm, it worked.

Tried the same on xterm with AA fonts, it worked.

Machine is Athlon 900, 256mb ram, nvidia tnt1 card with standard nv.o Xfree
driver (no nvidia driver).

Comment 1 Antonio Vargas 2003-04-18 13:42:11 UTC
Created attachment 91188 [details]
Complete list of installed packages

Comment 2 Warren Togami 2003-04-19 08:10:32 UTC
I have reproduced this.  Anything that causes lots of text to fly by quickly in
gnome-terminal can cause this lockup when using kernel-2.5.x.

Workaround: If you start a process that has lots of text flying by, but minimize
the window, it wont lockup.

Comment 3 Jan "Yenya" Kasprzak 2003-07-22 13:20:13 UTC
I have reproduced this - even running "make menuconfig" locks up the terminal,
when it is vertically maximized.

However - I've first experienced this after booting to 2.6.0-test1 kernel
with CONFIG_PREEMPT=y.

Comment 4 Antonio Vargas 2003-07-22 15:28:16 UTC
I was running the standard 2.4.x kernel when I saw it.

According to linux-kernel mailing list, this is an application bug uncovered by
the new O(1) scheduler.

Relevant thread:

http://mail.nl.linux.org/linux-mm/2003-07/msg00275.html

Message-ID: <6uwueidhdd.fsf@zork.zork.net>



Comment 5 Ray Strode [halfline] 2004-11-05 03:23:50 UTC
It sounds like this is an old kernel problem.  I'm going to close the
bug, but if people are still experiencing problems using recent
packages, please feel free to reopen.