Bug 891648

Summary: clarify the disadvantages of enumeration in sssd.conf
Product: Red Hat Enterprise Linux 7 Reporter: Dmitri Pal <dpal>
Component: sssdAssignee: Jakub Hrozek <jhrozek>
Status: CLOSED CURRENTRELEASE QA Contact: Kaushik Banerjee <kbanerje>
Severity: unspecified Docs Contact:
Priority: low    
Version: 7.0CC: apeetham, grajaiya, jgalipea, pbrezina
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: sssd-1.10.0-1.el7.alpha1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 988381 (view as bug list) Environment:
Last Closed: 2014-06-13 10:44:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 988381    

Description Dmitri Pal 2013-01-03 14:28:05 UTC
The actual work will be done in here.

This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/1732

Many users set enumerate=true in their configuration for convenience of being able to access all the users. We should explain that enumeration might not be a great idea in big environments due to bugs like #1729.

Comment 2 Dmitri Pal 2013-01-03 15:01:37 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1737

Comment 3 Jakub Hrozek 2013-03-26 18:08:16 UTC
Fixed upstream.

Comment 4 Jakub Hrozek 2013-10-04 13:23:02 UTC
Temporarily moving bugs to MODIFIED to work around errata tool bug

Comment 6 Amith 2013-12-11 15:07:19 UTC
Verified the bug on SSSD Version: sssd-1.11.2-10.el7.x86_64

Comment 7 Ludek Smid 2014-06-13 10:44:01 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.