This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 893098

Summary: No login on the Xfce spin
Product: [Fedora] Fedora Reporter: Christoph Wickert <cwickert>
Component: LiveCD - XfceAssignee: Kevin Fenzi <kevin>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 18CC: awilliam
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-02 21:22:59 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752665, 863722    

Description Christoph Wickert 2013-01-08 10:19:42 EST
Description of problem:
The Xfce spin (currently RC2) doesn't do autologin because lightdm's timed login does not work. "liveuser" is not selected  and shown by default in the user list dropdown. After selecting the user, one needs to click 'Login' with an empty password. This is everything but intuitive.

Version-Release number of selected component (if applicable):
F18 RC2 Xfce Live
Comment 1 Christoph Wickert 2013-01-08 10:29:38 EST
Fixed in 
http://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=976ec23 (master)
http://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f18&id=6e971b4 (F18)

We now need a new spin-kickstarts package.
Comment 2 Adam Williamson 2013-01-08 13:18:48 EST
+1 NTH, obviously a significant effect on login to Xfce spin, and doesn't require package changes so we can respin Xfce without poking anything else.
Comment 3 Christoph Wickert 2013-01-08 17:08:03 EST
There was yet another problem: Xfce was not set as default session. Fixed in:
http://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=81d56bc04 and 
http://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f18&id=7083cbf
Comment 4 Adam Williamson 2013-01-08 17:58:05 EST
I built a test image with the latest spin-kickstarts, I got an automatic login (no timeout or anything, it just boots and logs me in). If that's what's intended, it's working.

liveinst pops up some warning about the installer location, but works if you click through the warning. Logging into the installed system is as described above, the drop-down box doesn't select any user by default, you have to pick the user you just created then enter the password. Bit creaky, but it works.
Comment 5 Christoph Wickert 2013-01-08 18:09:52 EST
(In reply to comment #4)
> I built a test image with the latest spin-kickstarts, I got an automatic
> login (no timeout or anything, it just boots and logs me in). If that's
> what's intended, it's working.

Yes, that's the intended behavior.

> liveinst pops up some warning about the installer location, but works if you
> click through the warning.

Weird. I assume that doesn't have anything to do with the spin itself. Did you see it with any of the other live media?

> Logging into the installed system is as described
> above, the drop-down box doesn't select any user by default, you have to
> pick the user you just created then enter the password. Bit creaky, but it
> works.

Yeah, lightdm still needs more work. It remembers the last user, but when you boot up for the first time, the dropdown is/seems empty.
Comment 6 Christoph Wickert 2013-01-08 18:17:56 EST
(In reply to comment #4)

> liveinst pops up some warning about the installer location, but works if you
> click through the warning. 

Interesting, never saw this 'feature' before, I only know it from KDE. Fixed in 
http://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=2f7d13c and
http://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f18&id=fec09c7
Comment 7 Adam Williamson 2013-01-08 21:51:49 EST
all looks good with latest kickstarts, dgilmore says he'll do an RC2.2 soon.