Bug 893375

Summary: [abrt] coreutils-8.15-7.fc17: pause: Process /usr/bin/sleep was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Jiri Moskovcak <jmoskovc>
Component: coreutilsAssignee: Ondrej Vasik <ovasik>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: admiller, dfediuck, kdudka, kzak, ovasik, p, twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:bf5872865f2f92a7cee40e3c58867036a315c3ac
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-09 04:31:08 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: backtrace
none
File: cgroup
none
File: core_backtrace
none
File: dso_list
none
File: environ
none
File: limits
none
File: maps
none
File: open_fds
none
File: var_log_messages
none
File: screencast.ogv none

Description Jiri Moskovcak 2013-01-09 04:29:12 EST
Description of problem:
somethinga sasda

Version-Release number of selected component:
coreutils-8.15-7.fc17

Additional info:
backtrace_rating: 4
cmdline:        sleep 100
crash_function: pause
executable:     /usr/bin/sleep
kernel:         3.5.3-1.fc17.x86_64
remote_result:  696222
smolt_data:     
uid:            1001

Truncated backtrace:
[New LWP 2392]
warning: Could not load shared library symbols for %0*Zx, 0x%0*Zx).
Do you need "set solib-search-path" or "set sysroot"?
Core was generated by `sleep 100'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007f71537f86b0 in pause () at ../sysdeps/unix/syscall-template.S:84
84	T_PSEUDO_END (SYSCALL_SYMBOL)

Thread 1 (LWP 2392):
#0  0x00007f71537f86b0 in pause () at ../sysdeps/unix/syscall-template.S:84
No locals.
#1  0x0000000000403b97 in rpl_nanosleep (requested_delay=requested_delay@entry=0x7fff00621ca0, remaining_delay=remaining_delay@entry=0x0) at nanosleep.c:85
        limit = 2073600
        seconds = 100
        intermediate = {tv_sec = 100, tv_nsec = 0}
#2  0x0000000000403a2a in xnanosleep (seconds=seconds@entry=100) at xnanosleep.c:51
        ts_sleep = {tv_sec = 100, tv_nsec = 0}
#3  0x00000000004015a4 in main (argc=<optimized out>, argv=<optimized out>) at sleep.c:147
        i = <optimized out>
        seconds = <optimized out>
        ok = <optimized out>
From                To                  Syms Read   Shared Object Library
0x00007f715375cf60  0x00007f715389d7a0  Yes         /lib64/libc.so.6
0x00007f7153af5b20  0x00007f7153b0f2e9  Yes         /lib64/ld-linux-x86-64.so.2
                                        No          %0*Zx, 0x%0*Zx)
$1 = 0x0
No symbol "__glib_assert_msg" in current context.
rax            0xfffffffffffffdfc	-516
rbx            0x64	100
rcx            0xffffffffffffffff	-1
rdx            0x0	0
rsi            0x0	0
rdi            0x7fff00621c60	140733199817824
rbp            0x0	0x0
rsp            0x7fff00621c58	0x7fff00621c58
r8             0x0	0
r9             0x0	0
r10            0x7fff006219f0	140733199817200
r11            0x246	582
r12            0x401940	4200768
r13            0x7fff00621e18	140733199818264
r14            0x0	0
r15            0x0	0
rip            0x7f71537f86b0	0x7f71537f86b0 <pause+80>
eflags         0x246	[ PF ZF IF ]
cs             0x33	51
ss             0x2b	43
ds             0x0	0
es             0x0	0
fs             0x0	0
gs             0x0	0
Dump of assembler code for function pause:
   0x00007f71537f8660 <+0>:	cmpl   $0x0,0x2fbb4d(%rip)        # 0x7f7153af41b4 <__libc_multiple_threads>
   0x00007f71537f8667 <+7>:	jne    0x7f71537f8679 <pause+25>
   0x00007f71537f8669 <+0>:	mov    $0x22,%eax
   0x00007f71537f866e <+5>:	syscall 
   0x00007f71537f8670 <+7>:	cmp    $0xfffffffffffff001,%rax
   0x00007f71537f8676 <+13>:	jae    0x7f71537f86a9 <pause+73>
   0x00007f71537f8678 <+15>:	retq   
   0x00007f71537f8679 <+25>:	sub    $0x8,%rsp
   0x00007f71537f867d <+29>:	callq  0x7f715383d4b0 <__libc_enable_asynccancel>
   0x00007f71537f8682 <+34>:	mov    %rax,(%rsp)
   0x00007f71537f8686 <+38>:	mov    $0x22,%eax
   0x00007f71537f868b <+43>:	syscall 
   0x00007f71537f868d <+45>:	mov    (%rsp),%rdi
   0x00007f71537f8691 <+49>:	mov    %rax,%rdx
   0x00007f71537f8694 <+52>:	callq  0x7f715383d510 <__libc_disable_asynccancel>
   0x00007f71537f8699 <+57>:	mov    %rdx,%rax
   0x00007f71537f869c <+60>:	add    $0x8,%rsp
   0x00007f71537f86a0 <+64>:	cmp    $0xfffffffffffff001,%rax
   0x00007f71537f86a6 <+70>:	jae    0x7f71537f86a9 <pause+73>
   0x00007f71537f86a8 <+72>:	retq   
   0x00007f71537f86a9 <+73>:	mov    0x2f5780(%rip),%rcx        # 0x7f7153aede30
=> 0x00007f71537f86b0 <+80>:	xor    %edx,%edx
   0x00007f71537f86b2 <+82>:	sub    %rax,%rdx
   0x00007f71537f86b5 <+85>:	mov    %edx,%fs:(%rcx)
   0x00007f71537f86b8 <+88>:	or     $0xffffffffffffffff,%rax
   0x00007f71537f86bc <+92>:	jmp    0x7f71537f86a8 <pause+72>
End of assembler dump.
Comment 1 Jiri Moskovcak 2013-01-09 04:29:15 EST
Created attachment 675345 [details]
File: backtrace
Comment 2 Jiri Moskovcak 2013-01-09 04:29:19 EST
Created attachment 675346 [details]
File: cgroup
Comment 3 Jiri Moskovcak 2013-01-09 04:29:22 EST
Created attachment 675347 [details]
File: core_backtrace
Comment 4 Jiri Moskovcak 2013-01-09 04:29:24 EST
Created attachment 675348 [details]
File: dso_list
Comment 5 Jiri Moskovcak 2013-01-09 04:29:27 EST
Created attachment 675349 [details]
File: environ
Comment 6 Jiri Moskovcak 2013-01-09 04:29:29 EST
Created attachment 675350 [details]
File: limits
Comment 7 Jiri Moskovcak 2013-01-09 04:29:31 EST
Created attachment 675351 [details]
File: maps
Comment 8 Jiri Moskovcak 2013-01-09 04:29:33 EST
Created attachment 675352 [details]
File: open_fds
Comment 9 Jiri Moskovcak 2013-01-09 04:29:35 EST
Created attachment 675353 [details]
File: var_log_messages
Comment 10 Jiri Moskovcak 2013-01-09 04:29:39 EST
Created attachment 675354 [details]
File: screencast.ogv
Comment 11 Jiri Moskovcak 2013-01-09 04:31:08 EST
Sorry, not a bug, please disregard.